Bug 768802 - Newline validation on leading and trailing string.
Newline validation on leading and trailing string.
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Usability (Show other bugs)
1.5
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alex Eng
Ding-Yi Chen
: UserStory
: 746140 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-18 21:06 EST by Alex Eng
Modified: 2012-04-23 00:33 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-23 00:33:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Eng 2011-12-18 21:06:35 EST
Description of problem:

Message strings often contain escape sequences like newlines or tabs and any mismatch in their position or number may result in an error to be generated for the translation file.

This story is just for leading and trailing newline. 

This will be for '\n' sequence.
Comment 1 Alex Eng 2011-12-18 23:17:56 EST
Implemented in 1.5. See https://github.com/zanata/zanata/commit/d4e942d8d1d6420f561d003c6e181e6744894e87
Comment 2 David Mason 2012-01-05 22:16:24 EST
Does not detect when newlines are present in the target but not the source. Validation should detect these cases given that any mismatch could result in an error.

Properly detects when leading and trailing newlines are present in the source but not the target.

A number of strings in Hibernate Core have a trailing newline followed by 8 spaces. This looks like a trailing newline but is technically just trailing whitespace and is not reported as missing by this validator - it is unclear how this should be treated, this could require an enhancement in the future for validating arbitrary leading/trailing whitespace.
Comment 4 David Mason 2012-01-19 02:35:00 EST
 - updated to use localisable message strings
 - updated tag order algorithm to detect single moved tag
 - updated printf matching regex to match most standard variable patterns

See
https://github.com/zanata/zanata/commit/f8eaaa0666357c6fe284d6cf4618650ec3513fc0
https://github.com/zanata/zanata/compare/e69ee68374a74eac8535980bc7dd833ba7795b83...030653ed8063238147f95b7219d0838f75150194
Comment 6 David Mason 2012-02-09 23:14:10 EST
*** Bug 746140 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.