Bug 769119 - reinstalling kernel results in 2 grub2 entries
reinstalling kernel results in 2 grub2 entries
Status: CLOSED DUPLICATE of bug 751603
Product: Fedora
Classification: Fedora
Component: grubby (Show other bugs)
rawhide
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-19 19:55 EST by Andre Robatino
Modified: 2011-12-28 11:29 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-28 11:29:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andre Robatino 2011-12-19 19:55:07 EST
Description of problem:
If I start with grub.cfg generated by grub2-mkconfig, and then reinstall an existing kernel (if necessary booting into a different one first), grubby generates an extra grub2 entry for it without deleting the existing entry generated by grub2-mkconfig, so there will be 2 grub2 entries for that kernel. I first saw this on Rawhide with the latest grubby-8.6-1.fc17 (see https://bugzilla.redhat.com/show_bug.cgi?id=768645#c8 ) but was then able to reproduce it on F16, so this is not a new bug.

Version-Release number of selected component (if applicable):
grubby-8.6-1.fc17
Comment 1 Jaroslav Pulchart 2011-12-28 03:52:54 EST
Looks like duplicate of 751603.
Comment 2 Andre Robatino 2011-12-28 11:29:32 EST

*** This bug has been marked as a duplicate of bug 751603 ***

Note You need to log in before you can comment on or make changes to this bug.