Bug 769537 - html test fails with OOM
html test fails with OOM
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: perl-XML-LibXML (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Pisar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-21 04:26 EST by Dan Horák
Modified: 2012-08-13 20:59 EDT (History)
3 users (show)

See Also:
Fixed In Version: perl-XML-LibXML-2.0003-2.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-13 20:59:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dan Horák 2011-12-21 04:26:52 EST
The html test fails with OOM on ppc64 and s390x (64-bit big endians)

...
t/10ns.t ............................ ok       
t/11memory.t ........................ skipped: developers only (set MEMORY_TEST=1 to run these tests)
t/12html.t .......................... 1/43 Out of memory!
# Looks like you planned 43 tests but ran 41.
# Looks like your test exited with 1 just after 41.
t/12html.t .......................... Dubious, test returned 1 (wstat 256, 0x100)
Failed 2/43 subtests 
t/13dtd.t ........................... ok     
t/14sax.t ........................... ok     
t/15nodelist.t ...................... ok     
...

package version: perl-XML-LibXML-1.88-1.fc17
Comment 1 Sandro CAZZANIGA 2012-07-05 03:54:30 EDT
Hi, it's seems fixed with the latest version of the perl module (2.0001):

chmod 755 blib/arch/auto/XML/LibXML/LibXML.so
cp LibXML.bs blib/arch/auto/XML/LibXML/LibXML.bs
chmod 644 blib/arch/auto/XML/LibXML/LibXML.bs
PERL_DL_NONLAZY=1 /usr/bin/perl5.16.0 "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/01basic.t ......................... 1/3 # 
# 
# Compiled against libxml2 version: 20800
# Running libxml2 version:          20800
# 
t/01basic.t ......................... ok   
t/02parse.t ......................... ok       
t/03doc.t ........................... ok       
t/04node.t .......................... ok       
t/05text.t .......................... ok     
t/06elements.t ...................... ok       
t/07dtd.t ........................... ok     
t/08findnodes.t ..................... ok     
t/09xpath.t ......................... ok     
t/10ns.t ............................ ok       
t/11memory.t ........................ skipped: developers only (set MEMORY_TEST=1 to run these tests)
t/12html.t .......................... ok     
t/13dtd.t ........................... ok     
t/14sax.t ........................... ok     
t/15nodelist.t ...................... ok     
t/16docnodes.t ...................... ok     
t/17callbacks.t ..................... ok  

Maybe with versions between 1.88 and 2.0001, don't know.
Comment 2 Sandro CAZZANIGA 2012-07-05 04:09:17 EDT
Hmm, 

I can't reproduce this bug in tests with XML-LibXML-1.88..
Comment 3 Dan Horák 2012-07-06 06:51:53 EDT
(In reply to comment #2)
> Hmm, 
> 
> I can't reproduce this bug in tests with XML-LibXML-1.88..

are you working with a 64-bit big-endian system (ppc64, s390x) or with regular x86_64 (which is little-endian)?
Comment 4 Sandro CAZZANIGA 2012-07-06 08:05:18 EDT
No.
Comment 5 Petr Pisar 2012-08-03 07:58:31 EDT
This issue has been resolved as bug #845534. I will re-enable the 12html test.
Comment 6 Fedora Update System 2012-08-03 08:28:05 EDT
perl-XML-LibXML-1.90-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/perl-XML-LibXML-1.90-3.fc17
Comment 7 Fedora Update System 2012-08-05 17:32:30 EDT
Package perl-XML-LibXML-1.90-3.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing perl-XML-LibXML-1.90-3.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-11523/perl-XML-LibXML-1.90-3.fc17
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2012-08-13 20:59:21 EDT
perl-XML-LibXML-1.90-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.