Bug 845534 - Failing usptream test 12html.t
Failing usptream test 12html.t
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: perl-XML-LibXML (Show other bugs)
17
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-03 07:10 EDT by Petr Pisar
Modified: 2012-08-13 20:59 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 839331
Environment:
Last Closed: 2012-08-13 20:59:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
CPAN 77340 None None None 2012-08-03 07:10:34 EDT

  None (edit)
Description Petr Pisar 2012-08-03 07:10:34 EDT
+++ This bug was initially created as a clone of Bug #839331 +++

Description of problem:
When upstream test suite is run, it fails on 12html.t:

t/12html.t .. 1/43 Out of memory!
# Looks like you planned 43 tests but ran 41.
# Looks like your test exited with 1 just after 41.
t/12html.t .. Dubious, test returned 1 (wstat 256, 0x100)
Failed 2/43 subtests 

Test Summary Report
-------------------
t/12html.t (Wstat: 256 Tests: 41 Failed: 0)
  Non-zero exit status: 1
  Parse errors: Bad plan.  You planned 43 tests but ran 41.
Files=1, Tests=41,  0 wallclock secs ( 0.04 usr  0.02 sys +  0.08 cusr  0.04 csys =  0.18 CPU)
Result: FAIL

Version-Release number of selected component (if applicable):
perl-XML-LibXML-1.90-1

How reproducible:
always on ppc64, s390x

[...]

--- Additional comment from ppisar@redhat.com on 2012-08-03 10:46:24 GMT ---

Reproducer:
$ perl -MXML::LibXML \
  -e 'XML::LibXML->new->parse_html_string(q{<body>})->toStringHTML;'
Out of memory!

--- Additional comment from ppisar@redhat.com on 2012-08-03 10:55:51 GMT ---

Upstream has fixed this issue in 1.99 with commit:

# HG changeset patch
# User Shlomi Fish <shlomif@shlomifish.org>
# Date 1338446967 -10800
# Node ID 35fba7a70067f4f9393e26d9d478e761fe65b47d
# Parent  0da8582cfa03ef4a4516374796acaf3c6d9d8c96
Fix functionality on 64-bit big-endian platforms.

https://rt.cpan.org/Ticket/Display.html?id=77340 .

----

F17 affected.
Comment 1 Fedora Update System 2012-08-03 07:43:51 EDT
perl-XML-LibXML-1.90-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/perl-XML-LibXML-1.90-2.fc17
Comment 2 Petr Pisar 2012-08-03 07:48:02 EDT
The failing tests was not run before because it was disabled for the same bug (The failing tests has been). The test must be re-enabled.
Comment 3 Fedora Update System 2012-08-05 17:32:24 EDT
Package perl-XML-LibXML-1.90-3.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing perl-XML-LibXML-1.90-3.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-11523/perl-XML-LibXML-1.90-3.fc17
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2012-08-13 20:59:14 EDT
perl-XML-LibXML-1.90-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.