Bug 769861 - [as4 and as5 plugins] add maxThreads trait to JBossAS Embedded JBossWeb Connector Resources
[as4 and as5 plugins] add maxThreads trait to JBossAS Embedded JBossWeb Conne...
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
3.0.1
Unspecified Unspecified
high Severity low (vote)
: ---
: JON 3.1.0,RHQ 4.3.0
Assigned To: Larry O'Leary
Mike Foley
:
: 786165 (view as bug list)
Depends On:
Blocks: jon310-sprint11/rhq44-sprint11 794765
  Show dependency treegraph
 
Reported: 2011-12-22 10:05 EST by Mohamed Hamza Ben Mansour
Modified: 2013-03-14 11:06 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 794765 (view as bug list)
Environment:
Last Closed: 2013-03-14 11:06:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
the patch to add the feature (against 3.0.1.GA) (4.10 KB, patch)
2011-12-22 10:07 EST, Mohamed Hamza Ben Mansour
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker PRODMGT-109 Major Closed Add maxThreads as a trait metric for the Embedded Tomcat Server -> Connector resource 2013-06-19 08:50:14 EDT

  None (edit)
Description Mohamed Hamza Ben Mansour 2011-12-22 10:05:51 EST
Description of problem:

The maxThreads information for tomcat connectors is present in the case of a standalone Tomcat server. However it is not fetched for the JBoss embedded Tomcat servers. This information can be very useful particularly for my customer EUROPCAR. Indeed, he wants to have different groups of connector thread pools grouped by their respective maxthreads. 

Version-Release number of selected component (if applicable):
3.0.1

How reproducible:
Always

Steps to Reproduce:
1. modify the rhq-plugin.xml for the jopr-jboss-as-plugin and add for the Connector service :
<!-- jboss.web:name=http-0.0.0.0-8080,type=ThreadPool:maxThreads -->
            <metric property="jboss.web:name=%schema%%dash%%address%-%port%,type=ThreadPool:maxThreads"
                    displayName="Threadpool Max Threads."
                    defaultOn="true" category="utilization" displayType="detail" dataType="trait" measurementType="dynamic"/>

2. Perform a plugin update for agents
3.
  
Actual results:
"Not found" displayed in the Trait sub-tab

Expected results:
The actual maxThreads value

Additional info:
Attached the patch against the 3.0.1.GA wich adds the information both for the AS 5 and AS plugins
Comment 1 Mohamed Hamza Ben Mansour 2011-12-22 10:07:07 EST
Created attachment 549207 [details]
the patch to add the feature (against 3.0.1.GA)
Comment 3 Larry O'Leary 2012-02-02 14:04:25 EST
*** Bug 786165 has been marked as a duplicate of this bug. ***
Comment 4 Charles Crouch 2012-02-15 08:18:43 EST
Lets see if we can use the patch Mohamed has provided, assuming he can confirm he has signed the Fedora CLA
Comment 5 Shaun Appleton 2012-02-15 08:46:13 EST
As Mohamed is a Red Hat employee I think he has signed it by default.
Comment 6 Charles Crouch 2012-02-16 10:45:29 EST
(In reply to comment #5)
> As Mohamed is a Red Hat employee I think he has signed it by default.

My bad, I should have checked his email address. Thanks for the pointer Shaun.

Lets see if this patch applies cleanly in master.
This feature should also be added to the as7 plugin for consistency.
Comment 7 Ian Springer 2012-02-17 10:09:41 EST
Merged patch into as4 and as5 plugins:

http://git.fedorahosted.org/git/?p=rhq/rhq.git;a=commitdiff;h=bf2b0ec

I will make a clone of this BZ to track the equivalent enhancement to the as7 plugin.
Comment 9 dsteigne 2012-05-14 10:18:39 EDT
Installed EAP 5.1 server and verified Trait was now available

Note You need to log in before you can comment on or make changes to this bug.