Bug 77090 - (440GX IRQ_ROUTING)Redhat 8.0 - Adaptec AIC-7896 Embedded SCSI Contoller on an Intel L440GX+ MB
(440GX IRQ_ROUTING)Redhat 8.0 - Adaptec AIC-7896 Embedded SCSI Contoller on a...
Status: CLOSED DUPLICATE of bug 79752
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-31 20:04 EST by Need Real Name
Modified: 2007-04-18 12:48 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:50:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from dmidecode (7.54 KB, text/plain)
2002-11-04 21:58 EST, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2002-10-31 20:04:16 EST
I resently downloaded the ISO for RedHat 8.0 (Will be happy to buy the box set 
if I can get this cleared up).  I have a Adaptec AIC-7896 Embedded SCSI 
Contoller on an Intel L440GX+ MB.  

I can install the OS without a hickup, but when it comes back around to reboot 
it scans the SCSI channels like a dog looking for a bone (takes about 20 
minutes), continues on then falls over dead.  I would go into all the errors 
and descriptions, but you can pretty much read bug# 29555 to get the exact 
idea.  That bug was for Redhat 7.1.  It seems the problem persists in 8.0 (or 
on the MB at least).  Has anyone heard anything new about this or is a dead 
issue?

I am a true Linux Newbie and would very much like to get my feet wet, if I can 
get the little booger to boot!

Please advise,

Doug Van Tilburg
Comment 1 Michael Fulbright 2002-11-01 11:24:01 EST
Assigning to kernel since this is happening after a successful install.
Comment 2 Arjan van de Ven 2002-11-01 11:27:25 EST
well for the 440GX bios bug you need to install the SMP kernel; if you install
(and use) that one it's supposed to just work
Comment 3 Need Real Name 2002-11-01 13:05:50 EST
Could you go over with me what I need to do to load the SMP kernel?  I know 
there are a couple steps, but not sure what.  Please bare in mind that this is 
a single processor system (one processor slot un-used).  I believe that makes a 
difference as well.

Thanks for responding so rapidly.
Comment 4 Arjan van de Ven 2002-11-01 14:04:00 EST
basically: boot from the cd in rescue mode, copy the
kernel-smp-2.4.18-14.i686.rpm to /mnt/sysroot/tmp and then chroot /mnt/sysroot
and then rpm -i /tmp/kernel-smp-2.4.18-14.i686.rpm 
Comment 5 Need Real Name 2002-11-04 12:18:01 EST
I was bitten by this bug as well (Intel L440GX+ mobo, 1 Processor, 
install went fine, system won't boot).

The suggested workaround (install and boot the SMP kernel) doesn't work for me.
The boot process hangs at:

    pty: 2048 Unix98 ptys configured

and I can't Ctrl-Alt-Del (I have to press the reset button).

If I boot `linux apic' I hang at the next line in the boot process:

    Serial driver version 5.05c (2001-07-08) with MANY_PORTS MULTIPORT
        SHARE_IRQ SERIAL_PCI ISAPNP enabled

If I boot `linux-up' or `linux-up apic' the boot winds up reseting the
SCSI bus over and over.

I get the same result, booting from the boot floppy I made during the
installation.

I'll try to get the results from dmidecode and attach them, but this 
is very annoying since this bug has been a problem since Redhat Linux 7.1

Note: I installed the SMP kernel and the lilo boot loader during the
install process not afterwards. I don't think that should make a difference
though.
Comment 6 Need Real Name 2002-11-04 17:59:00 EST
Note: I was able to install Redhat Linux 7.3 with no trouble on the
same exact hardware by following the instructions in Bug #66852.
Comment 7 Need Real Name 2002-11-04 21:58:37 EST
Created attachment 83646 [details]
output from dmidecode
Comment 8 Need Real Name 2002-11-06 15:43:58 EST
Just adding a "me too" to Lenny's comment.  I was able to use the SMP-
kernel/APIC workaround to install RedHat 7.x on uniprocessor VALinux systems 
with the L440GX+ motherboard, but that workaround no longer works with RedHat 
8.0; after the install, subsequent boots hang after the "Serial driver version 
5.05c..." message is printed.  Up until now there's been slow forward progress 
in the installer's ability to handle the L440GX+ bug, but RedHat 8.0 appears to 
be a step backward.

I haven't tried the workaround yet on multiprocessor VALinux systems, so I 
don't know if it still works there.

I did also install RH8.0 on a VALinux 1220--which uses an ASUS CUR-DLS 
motherboard and a Symbios 53c896--and it now works even without explicitly 
specifying APIC (RH7.x installs on this hardware required the APIC workaround, 
as per bugid 60053).  So forward progress is being made with some hardware 
configurations, but not with the L440GX+.
Comment 9 Need Real Name 2002-11-27 15:09:10 EST
See bug 78234 for a workaround.  Basically, boot linux rescue, obtain linux
2.4.20-rc? (I used 4) and recompile kernel.  Works perfect.
Comment 10 Alan Cox 2003-06-08 07:29:36 EDT

*** This bug has been marked as a duplicate of 79752 ***
Comment 11 Red Hat Bugzilla 2006-02-21 13:50:04 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.