Bug 77096 - Include imap-utils, default to mbx format for speed
Summary: Include imap-utils, default to mbx format for speed
Status: CLOSED DUPLICATE of bug 63235
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: imap   
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-01 03:34 UTC by Bojan Smojver
Modified: 2007-04-18 16:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-04 01:55:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
New RPM spec file (20.26 KB, patch)
2002-11-01 03:40 UTC, Bojan Smojver
no flags Details | Diff
mbx patch (316 bytes, patch)
2002-11-01 03:42 UTC, Bojan Smojver
no flags Details | Diff
utils patch (488 bytes, patch)
2002-11-01 03:43 UTC, Bojan Smojver
no flags Details | Diff
spec patch: this should make it a bit easier (3.82 KB, patch)
2002-11-01 03:54 UTC, Bojan Smojver
no flags Details | Diff

Description Bojan Smojver 2002-11-01 03:34:59 UTC
Attached are the spec and a couple of patches that will put the following into
the imap RPM:

- mailbox creation defaults to mbx format for speed
- imap-utils is included

Bojan

Comment 1 Bojan Smojver 2002-11-01 03:40:03 UTC
Created attachment 83005 [details]
New RPM spec file

Comment 2 Bojan Smojver 2002-11-01 03:42:15 UTC
Created attachment 83006 [details]
mbx patch

Comment 3 Bojan Smojver 2002-11-01 03:43:01 UTC
Created attachment 83007 [details]
utils patch

Comment 4 Bojan Smojver 2002-11-01 03:44:03 UTC
Sorry, forgot to put my e-mail in the %changelog section. It should be:

* Fri Nov 01 2002 Bojan Smojver <bojan@rexursive.com>
- mbx creation patch, utils

Bojan

Comment 5 Bojan Smojver 2002-11-01 03:54:39 UTC
Created attachment 83008 [details]
spec patch: this should make it a bit easier

Comment 6 Mike A. Harris 2002-11-01 04:22:49 UTC

*** This bug has been marked as a duplicate of 63235 ***

Comment 7 Bojan Smojver 2002-11-04 01:55:27 UTC
OK, I understand your objections against imap-utils (as per 63235).

How about making mbx the default format of mailboxes? It works faster than Unix
folders and because they are accessed trough IMAP server anyway, majority of the
users won't have to deal with the change in any way.

Bojan

Comment 8 Mike A. Harris 2002-11-04 08:22:03 UTC
No, that is another request that I categorically will not institute.

UW imap basically isn't going to change from what it is right now.  I'd
rather replace the package with an alternative than modify it in any way
shape or form.  The problem here, is that there is no open community
process behind the software.  So if Red Hat modifies it, then we also
get to maintain it on our own.  Upstream developers would be very unlikely
to want to help out with any problems that arise.

As long as I maintain this package in the distro, it will remain more
or less as it is now, and close to stock as possible, in order to
minimize maintenance overhead.

If you want imap to change, ask the University of Washington to change it
at their level.  Thats the only way it will change in Red Hat Linux.  They
change it, then they maintain it that way.

Reclosing as a duplicate of bug #63235

Please do not reopen this bug again, as it just wastes my time to say
"no, I wont do that, reclosing bug yet again".



*** This bug has been marked as a duplicate of 63235 ***

Comment 9 Bojan Smojver 2002-11-04 09:36:27 UTC
OK. No worries. I'll be watching for the replacement. In the meantime, I'll roll
my own RPM.

Bojan


Note You need to log in before you can comment on or make changes to this bug.