Bug 63235 - Create rpms for imap-utils
Create rpms for imap-utils
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: imap (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
: FutureFeature
: 65028 77096 84513 84560 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-11 11:31 EDT by Nevin Kapur
Modified: 2007-04-18 12:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-30 03:25:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nevin Kapur 2002-04-11 11:31:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020311

Description of problem:
The UW imap server installation can be enhanced with many utilities that are
distributed in the imap-utils package.  Some of these like dmail, are quite
essential if say one wants to use procmail with imap. It would be nice if these
were official RPMs for this package.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Not relevant.

Additional info:

In order to install imap-utils, one actually needs the source for imap.  So it
is non-trivial to add this to a system where one has imap installed from RPMs. 
So currently if one wants to get these utilities, the cleanest way is to get rid
of the imap RPM and install both imap and imap-utils from source.
Comment 1 Mike A. Harris 2002-04-15 12:48:26 EDT
Deferring for consideration in a future release.
Comment 2 Mike A. Harris 2002-05-16 12:05:16 EDT
*** Bug 65028 has been marked as a duplicate of this bug. ***
Comment 3 Mike A. Harris 2002-05-30 03:28:28 EDT
I've investigated the tools, and I do not perceive them to be really
that useful to the wider userbase, but rather only to a very small
portion of the userbase.  Also, UW's licences for their software leave
a lot to be desired, as do the quality of their code, and the timeliness
of bugfixes to the public.

Due to all of these factors, I've decided not to add these utilities
to the distribution.
Comment 4 Nevin Kapur 2002-06-01 18:17:41 EDT
My rebuttal:

- I don't know any other way except using dmail to do server-side filtering with
   UW IMAP using the mbx format (the format recommended by the UW IMAP docs). 
So at least that particular program is crucial for me.

- If Red Hat doesn't trust UW's coding standards, why do they include their IMAP
server (something that handles mail) in their distribution?
Comment 6 Mike A. Harris 2002-10-31 23:22:42 EST
*** Bug 77096 has been marked as a duplicate of this bug. ***
Comment 7 Mike A. Harris 2002-10-31 23:25:48 EST
Just as an update to this occasionally recurring request... the license
of UW-imap is actually not the same as the pine license, so it is
aparently considerably open source after reading the license in the
latest sources when someone pointed this out to me.

Nonetheless....  this clarification does not change the resolution of this
request.  I just wanted to clear up the license issue.
Comment 8 Mike A. Harris 2002-11-04 03:21:56 EST
*** Bug 77096 has been marked as a duplicate of this bug. ***
Comment 9 Mike A. Harris 2004-02-27 05:14:49 EST
*** Bug 84560 has been marked as a duplicate of this bug. ***
Comment 10 Mike A. Harris 2004-02-27 05:15:32 EST
*** Bug 84513 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.