This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 77104 - TB Conf.py:936:__setitem__
TB Conf.py:936:__setitem__
Status: CLOSED DUPLICATE of bug 71171
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-01 03:38 EST by Ray Morris
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-01 03:38:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ray Morris 2002-11-01 03:38:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
Network configuration tool crashed upon clicking apply, 
reporting an error in conf.py.

Version-Release number of selected component (if applicable):
redhat-config-network 0.9.10-2

How reproducible:
Always

Steps to Reproduce:
1. On fresh RH7.2 install, run up2date to update redhat-config-network
2.Run redhat-config-network
3.Change host name
4.Click Apply
	

Actual Results:  Error message.  Changes are not saved/done.
Error trace is below.

Expected Results:  Changes should be made to proper files.

Additional info:

Traceback (innermost last):
  File "/usr/sbin/neat", line 1210, in ?
    gtk.mainloop()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2608, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/sbin/neat", line 392, in on_applyButton_clicked
    self.save()
  File "/usr/sbin/neat", line 271, in save
    self.saveHardware()
  File "/usr/sbin/neat", line 283, in saveHardware
    hardwarelist.save()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCHardwareList.py",
line 276, in save
    modules.write()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/Conf.py", line 981,
in write
    self[key] = self.vars[key]
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/Conf.py", line 936,
in __setitem__
    replace = key + ' ' + varname + ' ' + endofline
TypeError: illegal argument type for built-in operation

Local variables in innermost frame:
endofline: None
value: {'alias': None}
self: <netconfpkg.NCHardwareList.MyConfModules instance at 83e2d38>
varname: eth1
missing: 1
key: alias
place: 0
findexp: [	 ]*alias[	 ]+eth1[	 ]+
Comment 1 Harald Hoyer 2002-11-04 07:44:55 EST
first beta of erratum is available at:
ftp://people.redhat.com/harald/redhat-config-network/1.0.1-1/

Most of the bugs reported have been removed, but as in every software change,
there could be new bugs introduced.

Please report bugs against this with explicitly stating the 1.0.1 version... Thx
and please test.

*** This bug has been marked as a duplicate of 71171 ***

Note You need to log in before you can comment on or make changes to this bug.