Bug 771392 - [abrt] evolution-3.2.2-1.fc16: remove_queued_alarm: Process /usr/libexec/evolution/3.2/evolution-alarm-notify was killed by signal 11 (SIGSEGV)
[abrt] evolution-3.2.2-1.fc16: remove_queued_alarm: Process /usr/libexec/evol...
Status: CLOSED DUPLICATE of bug 675589
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
16
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
abrt_hash:f403a18f403db79915eebfa74c1...
:
Depends On: 715564
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-03 10:43 EST by Steve Carl
Modified: 2012-01-04 06:28 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-04 06:28:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: dso_list (8.50 KB, text/plain)
2012-01-03 10:43 EST, Steve Carl
no flags Details
File: build_ids (4.60 KB, text/plain)
2012-01-03 10:43 EST, Steve Carl
no flags Details
File: smolt_data (2.23 KB, text/plain)
2012-01-03 10:43 EST, Steve Carl
no flags Details
File: xsession_errors (12.45 KB, text/plain)
2012-01-03 10:43 EST, Steve Carl
no flags Details
File: maps (31.64 KB, text/plain)
2012-01-03 10:43 EST, Steve Carl
no flags Details
File: backtrace (32.48 KB, text/plain)
2012-01-03 10:43 EST, Steve Carl
no flags Details

  None (edit)
Description Steve Carl 2012-01-03 10:43:47 EST
libreport version: 2.0.7
abrt_version:   2.0.6
backtrace_rating: 4
cmdline:        /usr/libexec/evolution/3.2/evolution-alarm-notify
crash_function: remove_queued_alarm
executable:     /usr/libexec/evolution/3.2/evolution-alarm-notify
kernel:         3.1.4-1.fc16.i686
pid:            13866
pwd:            /home/steve
reason:         Process /usr/libexec/evolution/3.2/evolution-alarm-notify was killed by signal 11 (SIGSEGV)
time:           Tue 03 Jan 2012 09:19:54 AM CST
uid:            1000
username:       steve

backtrace:      Text file, 33256 bytes
build_ids:      Text file, 4715 bytes
dso_list:       Text file, 8709 bytes
maps:           Text file, 32397 bytes
smolt_data:     Text file, 2285 bytes
xsession_errors: Text file, 12748 bytes

environ:
:XDG_VTNR=1
:SSH_AGENT_PID=13833
:XDG_SESSION_ID=19
:SAL_USE_VCLPLUGIN=gtk
:HOSTNAME=bock.bmc.com
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:XDG_MENU_PREFIX=lxde-
:SHELL=/bin/bash
:TERM=dumb
:XDG_SESSION_COOKIE=f2c6da71d088d5988b315bd40000000d-1323792034.699783-41563133
:HISTSIZE=1000
:GNOME_KEYRING_CONTROL=/tmp/keyring-bvXIaW
:SYSFONT=latarcyrheb-sun16
:IMSETTINGS_MODULE=none
:USER=steve
:SSH_AUTH_SOCK=/tmp/ssh-ZbBuNcZ13678/agent.13678
:DESKTOP_SESSION=LXDE
:PATH=/usr/local/bin:/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/steve/.local/bin:/home/steve/bin
:MAIL=/var/spool/mail/steve
:LC_MESSAGES=en_US.utf8
:QT_IM_MODULE=xim
:PWD=/home/steve
:XMODIFIERS=@im=none
:GNOME_KEYRING_PID=13675
:LANG=en_US.utf8
:KEYTABLE=us
:SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
:HISTCONTROL=ignoredups
:XDG_SEAT=seat0
:HOME=/home/steve
:SHLVL=1
:XDG_CONFIG_HOME=/home/steve/.config
:LANGUAGE=en_US.utf8
:BOOT_IMAGE=/boot/vmlinuz-3.1.4-1.fc16.i686
:LOGNAME=steve
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-PxZZ1dVPfT,guid=43dd1f4f1c1fdd58b8a1a66a0000f880
:PREFERRED=/usr/bin/startlxde
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:XDG_RUNTIME_DIR=/run/user/steve
:DISPLAY=:0
:XAUTHORITY=/home/steve/.Xauthority
:_LXSESSION_PID=13678
:XDG_CURRENT_DESKTOP=LXDE

var_log_messages:
:Jan  3 09:19:54 bock kernel: [1875576.147688] evolution-alarm[13866]: segfault at f00dface ip 0804f44d sp bf8672c0 error 5 in evolution-alarm-notify.#prelink#.zTd0dg (deleted)[8048000+11000]
:Jan  3 09:19:54 bock abrt[20998]: File '/usr/libexec/evolution/3.2/evolution-alarm-notify.#prelink#.zTd0dg' seems to be deleted
:Jan  3 09:19:54 bock abrt[20998]: File '/usr/libexec/evolution/3.2/evolution-alarm-notify.#prelink#.zTd0dg' seems to be a prelink temporary file
:Jan  3 09:19:55 bock abrt[20998]: Saved core dump of pid 13866 (/usr/libexec/evolution/3.2/evolution-alarm-notify) to /var/spool/abrt/ccpp-2012-01-03-09:19:54-13866 (20934656 bytes)
Comment 1 Steve Carl 2012-01-03 10:43:50 EST
Created attachment 550453 [details]
File: dso_list
Comment 2 Steve Carl 2012-01-03 10:43:51 EST
Created attachment 550454 [details]
File: build_ids
Comment 3 Steve Carl 2012-01-03 10:43:53 EST
Created attachment 550455 [details]
File: smolt_data
Comment 4 Steve Carl 2012-01-03 10:43:54 EST
Created attachment 550456 [details]
File: xsession_errors
Comment 5 Steve Carl 2012-01-03 10:43:55 EST
Created attachment 550457 [details]
File: maps
Comment 6 Steve Carl 2012-01-03 10:43:56 EST
Created attachment 550458 [details]
File: backtrace
Comment 7 Tim Waugh 2012-01-04 04:24:48 EST
Happened when I logged in.

rating: 4
Package: evolution-3.2.2-1.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)
Comment 8 Milan Crha 2012-01-04 06:28:18 EST
Thanks for a bug report. This particular one had been reported already, thus I'm marking it as a duplicate. The report is against older evolution, but the issue seems to be still there. Its associated upstream bug report [1] lacks of reproducer steps, unfortunately. Being able to reproduce this reliably would help. The thing is that this most likely depends on event alarms, how the evolution-alarm-notification is updated with them. Once the event is processed the last notification time on its source is updated, thus the process is not notified with the same alarm again (the crash can do a little mess in it, but it rawfly apply).

[1] https://bugzilla.gnome.org/show_bug.cgi?id=641711

*** This bug has been marked as a duplicate of bug 675589 ***

Note You need to log in before you can comment on or make changes to this bug.