Bug 771624 - guest fails with error: isa irq 4 already assigned when starting guest with more than two serial devices
guest fails with error: isa irq 4 already assigned when starting guest with m...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.3
All Linux
urgent Severity high
: rc
: ---
Assigned To: Amit Shah
Virtualization Bugs
: Patch, ZStream
Depends On:
Blocks: 806717 840054
  Show dependency treegraph
 
Reported: 2012-01-04 06:36 EST by Xiaomei Gao
Modified: 2013-02-21 02:31 EST (History)
12 users (show)

See Also:
Fixed In Version: qemu-kvm-0.12.1.2-2.297.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 02:31:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch from Gerd Hoffmann (2.30 KB, patch)
2012-07-12 13:06 EDT, Neal Kim
no flags Details | Diff

  None (edit)
Description Xiaomei Gao 2012-01-04 06:36:00 EST
Description of problem:
when starting guest with two serial options, it works well. However, when starting guest with more than two serial options, guest fails with error:isa irq 4 already assigned. Also, man qemu-kvm says "this option can be used several times to simulate up to 4 serial ports."

Version-Release number of selected component (if applicable):
# uname -r
  2.6.32-220.el6.x86_64
# rpm -qa| grep qemu-kvm
  qemu-kvm-0.12.1.2-2.213.el6.x86_64

How reproducible:
100%


Steps to Reproduce:
1.boot a guest with two serial options
/usr/libexec/qemu-kvm -serial stdio -serial unix:/tmp/example,server,nowait
2.two serials work well
3.boot a guest with more than two serial options
/usr/libexec/qemu-kvm -serial stdio -serial unix:/tmp/example1,server,nowait -serial unix:/tmp/example2,server,nowait
4.guest fails with error:isa irq 4 already assigned
  
Expected results:
qemu-kvm should support 4 serial devices.

Additional info:
Comment 5 Neal Kim 2012-07-12 13:06:20 EDT
Created attachment 597855 [details]
Patch from Gerd Hoffmann
Comment 12 Shaolong Hu 2012-10-26 01:26:51 EDT
Verified with qemu-kvm-rhev-0.12.1.2-2.331.el6.x86_64:

[root@localhost nfs]# /usr/libexec/qemu-kvm -serial stdio -serial unix:/tmp/example1,server,nowait -serial unix:/tmp/example2,server,nowait
VNC server running on `::1:5900'
Comment 13 errata-xmlrpc 2013-02-21 02:31:50 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0527.html

Note You need to log in before you can comment on or make changes to this bug.