Bug 840054 - guest fails with error: isa irq 4 already assigned when starting guest with more than two serial devices
guest fails with error: isa irq 4 already assigned when starting guest with m...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.3
Unspecified Unspecified
urgent Severity high
: rc
: ---
Assigned To: Michal Novotny
Virtualization Bugs
: Patch, ZStream
Depends On: 771624
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-13 11:07 EDT by RHEL Product and Program Management
Modified: 2012-08-27 21:54 EDT (History)
18 users (show)

See Also:
Fixed In Version: qemu-kvm-0.12.1.2-2.295.el6_3.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-30 00:41:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description RHEL Product and Program Management 2012-07-13 11:07:23 EDT
This bug has been copied from bug #771624 and has been proposed
to be backported to 6.3 z-stream (EUS).
Comment 5 Shaolong Hu 2012-07-17 23:27:08 EDT
Reproduced with qemu-kvm-0.12.1.2-2.295.el6.x86_64:

[root@localhost ~]# /usr/libexec/qemu-kvm -serial unix:/tmp/u1,server,nowait -serial unix:/tmp/u2,server,nowait -serial unix:/tmp/u3,server,nowait
isa irq 4 already assigned

Verified on qemu-kvm-0.12.1.2-2.295.el6_3.1.x86_64:

[root@localhost ~]# /usr/libexec/qemu-kvm -serial unix:/tmp/u1,server,nowait -serial unix:/tmp/u2,server,nowait -serial unix:/tmp/u3,server,nowait -serial unix:/tmp/u4,server,nowait
VNC server running on `::1:5900'

[root@localhost ~]# /usr/libexec/qemu-kvm -serial unix:/tmp/u1,server,nowait -serial unix:/tmp/u2,server,nowait -serial unix:/tmp/u3,server,nowait -serial unix:/tmp/u4,server,nowait -serial unix:/tmp/u5,server,nowait
qemu: too many serial ports
Comment 8 errata-xmlrpc 2012-07-30 00:41:03 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1121.html

Note You need to log in before you can comment on or make changes to this bug.