Bug 771746 - Software Update claims all packages are untrusted
Software Update claims all packages are untrusted
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
16
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
: 772066 772310 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-04 15:13 EST by James
Modified: 2012-05-01 11:29 EDT (History)
15 users (show)

See Also:
Fixed In Version: PackageKit-0.6.21-2.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 814945 816025 (view as bug list)
Environment:
Last Closed: 2012-01-13 23:00:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description James 2012-01-04 15:13:15 EST
For reasons unknown, any attempt to use the Software Update or Add/Remove Software tools since Dec 31st results in an 'Authenticate' dialog. The text is 

"The software is not from a trusted source. Do not update these packages unless you are sure it is safe to do so."

Clicking on details gives the following:

Action: org.freedesktop.packagekit.package-install-untrusted
Vendor: The PackageKit Project

Testing indicates this dialog occurs for *any* package, from all the default repositories. I do not know why Software Update wants a root password as no changes to the repository configuration have been changed.
Comment 1 James 2012-01-08 10:10:46 EST
The problem started after these were installed:

PackageKit-yum-0.6.21-1.fc16.x86_64
PackageKit-0.6.21-1.fc16.x86_64
PackageKit-glib-0.6.21-1.fc16.x86_64
PackageKit-device-rebind-0.6.21-1.fc16.x86_64
PackageKit-yum-plugin-0.6.21-1.fc16.x86_64
Comment 2 Michael Cronenworth 2012-01-08 12:46:38 EST
*** Bug 772066 has been marked as a duplicate of this bug. ***
Comment 3 Richard Hughes 2012-01-09 08:20:11 EST
*** Bug 772310 has been marked as a duplicate of this bug. ***
Comment 4 Nils Philippsen 2012-01-09 08:35:48 EST
Reproduced this by downgrading zsh to what's in F-16 GA, then attempting to update.
Comment 5 Michael Cronenworth 2012-01-09 09:13:20 EST
(In reply to comment #4)
> Reproduced this by downgrading zsh to what's in F-16 GA, then attempting to
> update.

Are you sure you are replying to the correct bug, Nils? This has nothing to do with zsh.
Comment 6 Fedora Update System 2012-01-09 11:12:30 EST
PackageKit-0.6.21-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/PackageKit-0.6.21-2.fc16
Comment 7 Nils Philippsen 2012-01-09 11:13:13 EST
(In reply to comment #5)
> Are you sure you are replying to the correct bug, Nils? This has nothing to do
> with zsh.

Very sure, zsh was just the package I used as a guinea-pig here.
Comment 8 Michael Cronenworth 2012-01-09 11:16:52 EST
(In reply to comment #7)
> Very sure, zsh was just the package I used as a guinea-pig here.

OK. I read your comment wrong. Thanks for the quick fix. I'll give it some karma when I can.
Comment 9 James 2012-01-10 10:30:55 EST
Unfortunately I get a dependency error when attempting to test PackageKit-0.6.21-2.fc16.x86_64:

$>yum install PackageKit-0.6.21-2.fc16.x86_64.rpm PackageKit-glib-0.6.21-2.fc16.x86_64.rpm PackageKit-yum-0.6.21-2.fc16.x86_64.rpm

...

Error: Package: PackageKit-glib-0.6.21-1.fc16.i686 (updates)
           Requires: PackageKit = 0.6.21-1.fc16
           Removing: PackageKit-0.6.21-1.fc16.x86_64 (@updates)
               PackageKit = 0.6.21-1.fc16
           Updated By: PackageKit-0.6.21-2.fc16.x86_64 (/PackageKit-0.6.21-2.fc16.x86_64)
               PackageKit = 0.6.21-2.fc16
           Available: PackageKit-0.6.19-3.fc16.x86_64 (fedora)
               PackageKit = 0.6.19-3.fc16
Comment 10 Fedora Update System 2012-01-11 01:12:51 EST
Package PackageKit-0.6.21-2.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing PackageKit-0.6.21-2.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-0347/PackageKit-0.6.21-2.fc16
then log in and leave karma (feedback).
Comment 11 Nils Philippsen 2012-01-11 05:23:26 EST
(In reply to comment #9)
> Unfortunately I get a dependency error when attempting to test
> PackageKit-0.6.21-2.fc16.x86_64:
> 
> $>yum install PackageKit-0.6.21-2.fc16.x86_64.rpm
> PackageKit-glib-0.6.21-2.fc16.x86_64.rpm
> PackageKit-yum-0.6.21-2.fc16.x86_64.rpm

This is because 32bit and 64bit packages need to be in sync version-wise. Simply download the 32bit packages as well: PackageKit, PackageKit-glib
Comment 12 Fedora Update System 2012-01-13 23:00:31 EST
PackageKit-0.6.21-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2012-01-15 15:09:34 EST
PackageKit-0.6.21-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Josh Cogliati 2012-04-30 10:38:10 EDT
The same bug occurs with PackageKit-0.6.22-1.fc16.x86_64.
Comment 15 Michael Cronenworth 2012-04-30 10:44:24 EDT
(In reply to comment #14)
> The same bug occurs with PackageKit-0.6.22-1.fc16.x86_64.

Update your system:
https://admin.fedoraproject.org/updates/FEDORA-2012-6721/PackageKit-0.6.22-2.fc16
Comment 16 Josh Cogliati 2012-05-01 11:29:26 EDT
(In reply to comment #15)
> (In reply to comment #14)
> > The same bug occurs with PackageKit-0.6.22-1.fc16.x86_64.
> 
> Update your system:
> https://admin.fedoraproject.org/updates/FEDORA-2012-6721/PackageKit-0.6.22-2.fc16

Yep,  PackageKit-0.6.22-1.fc16.x86_64 fixes it.

Note You need to log in before you can comment on or make changes to this bug.