Bug 771845 - nfs:mount allowed even with *auth.reject is set
Summary: nfs:mount allowed even with *auth.reject is set
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: nfs (Show other bugs)
(Show other bugs)
Version: pre-release
Hardware: Unspecified Unspecified
high
high
Target Milestone: ---
Assignee: Vivek Agarwal
QA Contact:
URL:
Whiteboard:
Keywords:
: 799228 (view as bug list)
Depends On:
Blocks: 817967
TreeView+ depends on / blocked
 
Reported: 2012-01-05 08:47 UTC by Saurabh
Modified: 2016-02-18 00:03 UTC (History)
4 users (show)

Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 17:41:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions: 3.3.0qa29
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Saurabh 2012-01-05 08:47:58 UTC
Description of problem:

The problem is that the mount is allowed even if options auth.reject and nfs.rpc-auth-reject are set.


Version-Release number of selected component (if applicable):

glusterfs 3.3.0qa18 built on Dec 29 2011 01:49:17

How reproducible:


Steps to Reproduce:
1.create a volume
2.set options auth.reject and nfs.rpc-auth-reject, for a certain IP 
3. try mounting that volume from the node with the rejected IP
  
Actual results:
Mount happens.


Expected results:
Mount should not happen.

Additional info:

[root@RHEL6 nfs-regression]# gluster volume info dist-rep
 
Volume Name: dist-rep
Type: Distributed-Replicate
Status: Started
Number of Bricks: 3 x 2 = 6
Transport-type: tcp
Bricks:
Brick1: 10.1.11.101:/export-xfs/dr
Brick2: 10.1.11.102:/export-xfs/drr
Brick3: 10.1.11.101:/export-xfs/ddr
Brick4: 10.1.11.102:/export-xfs/ddrr
Brick5: 10.1.11.101:/export-xfs/dist-rep.1325653831
Brick6: 10.1.11.102:/export-xfs/dist-rep.1325653834
Options Reconfigured:
auth.reject: 10.1.11.160
nfs.rpc-auth-reject: 10.1.11.160

from node 10.1.11.160,

[root@RHSSA1 ~]# mount -t nfs -o vers=3,nolock 10.1.11.101:/dist-rep /mnt/nfs-test
[root@RHSSA1 ~]# ls /mnt/nfs-test/
f.1  f.2  f.3  f.n  run7165

Comment 1 Rajesh 2012-03-13 09:31:04 UTC
*** Bug 799228 has been marked as a duplicate of this bug. ***

Comment 2 Anand Avati 2012-03-14 10:11:05 UTC
CHANGE: http://review.gluster.com/2929 (rpc-lib/rpcsvc: nfs auth corrections) merged in master by Vijay Bellur (vijay@gluster.com)


Note You need to log in before you can comment on or make changes to this bug.