Bug 799228 - nfs.rpc-auth-allow and nfs.rpc-auth-reject not working as expected
nfs.rpc-auth-allow and nfs.rpc-auth-reject not working as expected
Status: CLOSED DUPLICATE of bug 771845
Product: GlusterFS
Classification: Community
Component: nfs (Show other bugs)
mainline
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Rajesh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-02 02:51 EST by Shwetha Panduranga
Modified: 2013-07-04 18:43 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-13 05:31:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
nfs log when nfs.rpc-auth-allow set (52.50 KB, application/octet-stream)
2012-03-02 02:52 EST, Shwetha Panduranga
no flags Details
nfs log when nfs.rpc-auth-reject set (83.41 KB, application/octet-stream)
2012-03-02 02:53 EST, Shwetha Panduranga
no flags Details

  None (edit)
Description Shwetha Panduranga 2012-03-02 02:51:40 EST
Description of problem:
Case1:-
------
when nfs.rpc-auth-allow is set to an ip_address, it should allow nfs mount request only from the ip_address specified as value to nfs.rpc-auth-allow.

Case2:-
-----
when nfs.rpc-auth-reject is set to an ip_address, any nfs mount requests from the ip_address should be rejected. 

Version-Release number of selected component (if applicable):
mainline

How reproducible:
often

Steps to Reproduce Case1:
-------------------------
1.gluster volume set <vol_name> nfs.rpc-auth-allow <client1>
2.mount -t nfs -o vers=3 <volume> <mount_point> from client1

Actual results:
[2012-03-02 18:42:16.653885] T [mount3.c:767:mnt3_check_client_net] 0-nfs-mount: Peer not allowed
[2012-03-02 18:42:16.653917] D [mount3.c:913:mnt3svc_mnt] 0-nfs-mount: Client mount not allowed

Expected results:
Client mount request should be allowed

Steps to Reproduce Case2:
-------------------------
1.gluster volume set <vol_name> nfs.rpc-auth-reject <client1>
2.mount -t nfs -o vers=3 <volume> <mount_point> from client1

Actual results:
mount request from client1 allowed.

Expected results:
Client mount request should not be allowed

Additional info:
Comment 1 Shwetha Panduranga 2012-03-02 02:52:59 EST
Created attachment 566999 [details]
nfs log when nfs.rpc-auth-allow set
Comment 2 Shwetha Panduranga 2012-03-02 02:53:54 EST
Created attachment 567000 [details]
nfs log when nfs.rpc-auth-reject set
Comment 3 Rajesh 2012-03-13 05:31:04 EDT

*** This bug has been marked as a duplicate of bug 771845 ***

Note You need to log in before you can comment on or make changes to this bug.