Bug 772242 - [abrt] kernel: kernel BUG at fs/inode.c:429!
[abrt] kernel: kernel BUG at fs/inode.c:429!
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Eric Sandeen
Fedora Extras Quality Assurance
abrt_hash:eb3a645b9ef47d42d7e3421ace3...
:
: 805730 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-06 10:02 EST by badseed
Modified: 2012-05-14 13:11 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-14 13:11:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description badseed 2012-01-06 10:02:48 EST
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        BOOT_IMAGE=/boot/vmlinuz-3.1.6-1.fc16.x86_64 root=UUID=4e3dde9b-cd50-46ad-b3cb-e35c60e8bbd9 ro rd.md=0 rd.lvm=0 rd.dm=0 quiet SYSFONT=latarcyrheb-sun16 rhgb rd.luks=0 KEYTABLE=fr_CH LANG=en_US.UTF-8
comment:        switching off bluetooth from the panel
kernel:         3.1.6-1.fc16.x86_64
reason:         kernel BUG at fs/inode.c:429!
time:           ven 06 jan 2012 16:01:52 CET

backtrace:
:kernel BUG at fs/inode.c:429!
:invalid opcode: 0000 [#1] SMP 
:CPU 0 
:Modules linked in: tcp_lp hidp ppdev parport_pc lp parport fuse ebtable_nat ebtables lockd ipt_MASQUERADE iptable_nat nf_nat xt_CHECKSUM iptable_mangle tun bridge fcoe libfcoe libfc scsi_transport_fc scsi_tgt 8021q garp stp llc rfcomm bnep ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter ip6_tables nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack snd_hda_codec_hdmi snd_hda_codec_conexant arc4 cdc_ncm usbnet iwlwifi mac80211 cfg80211 thinkpad_acpi btusb bluetooth rfkill uvcvideo videodev cdc_acm snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm snd_timer snd snd_page_alloc virtio_net kvm_intel kvm cdc_wdm r8169 sunrpc mii media v4l2_compat_ioctl32 uinput joydev soundcore iTCO_wdt iTCO_vendor_support i2c_i801 microcode sdhci_pci sdhci mmc_core wmi i915 drm_kms_helper drm i2c_algo_bit i2c_core video [last unloaded: scsi_wait_scan]
:Pid: 14602, comm: udevd Not tainted 3.1.6-1.fc16.x86_64 #1 LENOVO 44014PG/44014PG
:RIP: 0010:[<ffffffff8118b8bc>]  [<ffffffff8118b8bc>] end_writeback+0x9c/0xa0
:RSP: 0018:ffff880133a6d9b8  EFLAGS: 00010213
:RAX: ffff88013002ac98 RBX: ffff88013002aac0 RCX: dead000000200200
:RDX: 0000000000000002 RSI: 0000000000000000 RDI: ffff88013002ac20
:RBP: ffff880133a6d9c8 R08: ffff88013002abc0 R09: ffffc90000002000
:R10: feb1fda2e89e4603 R11: 0000000000000001 R12: ffff88013002aac0
:R13: ffffffff816229c0 R14: ffffffff816229c0 R15: ffff88013002aac0
:FS:  00007f27e49e97c0(0000) GS:ffff88013fa00000(0000) knlGS:0000000000000000
:CS:  0010 DS: 0000 ES: 0000 CR0: 000000008005003b
:CR2: 00007fff5d580000 CR3: 00000001158e9000 CR4: 00000000000426e0
:DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
:DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
:Process udevd (pid: 14602, threadinfo ffff880133a6c000, task ffff88013f981730)
:Stack:
: ffff880133a6d9c8 ffff880123ef1af0 ffff880133a6d9e8 ffffffff811e07d5
: ffff88013002aac0 ffff88013002abc0 ffff880133a6da18 ffffffff8118ba6a
: ffff880133a6da38 ffff88013002aac0 ffff88013002ab60 ffff880134789800
:Call Trace:
: [<ffffffff811e07d5>] sysfs_evict_inode+0x35/0x60
: [<ffffffff8118ba6a>] evict+0x9a/0x1a0
: [<ffffffff8118bc73>] iput+0x103/0x200
: [<ffffffff811e1a95>] sysfs_dentry_iput+0x35/0x40
: [<ffffffff8118879f>] d_kill+0x9f/0x100
: [<ffffffff8118899e>] shrink_dentry_list+0x19e/0x1d0
: [<ffffffff81188b13>] __shrink_dcache_sb+0x143/0x170
: [<ffffffff81188d39>] shrink_dcache_parent+0x1f9/0x270
: [<ffffffff811e17db>] sysfs_dentry_revalidate+0x9b/0xd0
: [<ffffffff8117f5f6>] do_lookup+0x236/0x3a0
: [<ffffffff8117fe61>] link_path_walk+0x141/0x880
: [<ffffffff8117fc4d>] ? path_init+0x2cd/0x3a0
: [<ffffffff811806d8>] path_lookupat+0x58/0x740
: [<ffffffff814ad39e>] ? __sys_recvmsg+0x17e/0x2e0
: [<ffffffff8117d91b>] ? getname_flags+0x3b/0x260
: [<ffffffff812b5857>] ? __strncpy_from_user+0x27/0x60
: [<ffffffff81180df1>] do_path_lookup+0x31/0xc0
: [<ffffffff81182209>] user_path_at_empty+0x59/0xa0
: [<ffffffff811b28a6>] ? sys_epoll_wait+0x96/0x450
: [<ffffffff81177672>] sys_readlinkat+0x42/0xb0
: [<ffffffff810ca312>] ? audit_syscall_entry+0x242/0x360
: [<ffffffff81014695>] ? math_state_restore+0x45/0x60
: [<ffffffff811776fb>] sys_readlink+0x1b/0x20
: [<ffffffff815dccc2>] system_call_fastpath+0x16/0x1b
:Code: 02 00 00 00 48 c7 c2 90 a7 18 81 be 07 00 00 00 e8 8a 7f 44 00 48 c7 83 98 00 00 00 60 00 00 00 48 83 c4 08 5b 5d c3 0f 0b 0f 0b <0f> 0b 0f 0b 55 48 89 e5 53 48 83 ec 08 66 66 66 66 90 48 89 fb 
:RIP  [<ffffffff8118b8bc>] end_writeback+0x9c/0xa0
: RSP <ffff880133a6d9b8>

smolt_data:
:
:
:Général
:=================================
:UUID: 08650b0c-3339-4bef-870a-0c4455275fef
:SE: Fedora release 16 (Verne)
:Niveau d'exécution par défaut: Unknown
:Langue: fr_CH.utf8
:Plateforme: x86_64
:BogoMIPS: 4589.89
:Fabricant du processeurs: GenuineIntel
:Modèle de processeur: Intel(R) Core(TM) i5-2410M CPU @ 2.30GHz
:Stepping du processeur: 7
:Famille de processeur: 6
:Modèle du processeur: 42
:Nombre de processeurs: 4
:Vitesse du processeur: 2301
:Mémoire du système: 3866
:Swap du système: 4499
:Fabricant: LENOVO
:Système: 44014PG ThinkPad Edge E420s
:Type d'ordinateur: Notebook
:Noyau: 3.1.6-1.fc16.x86_64
:SELinux activé: 1
:Stratégie SELinux: targeted
:SELinux strict: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Périphériques
:=================================
:(6523:9106:6058:8676) pci, sdhci-pci, BASE, SD/MMC Host Controller
:(32902:7241:6058:8676) pci, None, PCI/ISA, HM65 Express Chipset Family LPC Controller
:(6523:9105:6058:8676) pci, None, BASE, Standard SD Host Controller
:(32902:278:6058:8676) pci, i915, VIDEO, 2nd Generation Core Processor Family Integrated Graphics Controller
:(32902:7190:6058:8676) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 4
:(32902:7184:6058:8676) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 1
:(32902:7186:6058:8676) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 2
:(32902:7200:6058:8676) pci, snd_hda_intel, MULTIMEDIA, 6 Series/C200 Series Chipset Family High Definition Audio Controller
:(4332:33128:6058:8673) pci, r8169, ETHERNET, RTL8111/8168B PCI Express Gigabit Ethernet controller
:(32902:7188:6058:8676) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 3
:(32902:7202:6058:8676) pci, i801_smbus, SERIAL, 6 Series/C200 Series Chipset Family SMBus Controller
:(32902:7171:6058:8676) pci, ahci, STORAGE, 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller
:(32902:7213:6058:8676) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2
:(32902:7206:6058:8676) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1
:(32902:260:6058:8676) pci, agpgart-intel, HOST/PCI, 2nd Generation Core Processor Family DRAM Controller
:(32902:7226:6058:8676) pci, None, SIMPLE, 6 Series/C200 Series Chipset Family MEI Controller #1
:(32902:132:32902:4885) pci, iwlwifi, NETWORK, Centrino Wireless-N 1000 BGN
:
:
:Informations sur le système de fichiers
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda2 / ext4 4096 4096 3023664 1098961 1068253 770048 601065 601065
:/dev/sda3 /home ext4 4096 4096 72758576 40283438 36587515 18481152 18357625 18357625
:
Comment 1 Josh Boyer 2012-01-06 10:11:39 EST
Was this after resuming from hibernate/suspend?
Comment 2 Eric Sandeen 2012-01-06 10:38:30 EST
418 void end_writeback(struct inode *inode)
419 {
420         might_sleep();
421         /*
422          * We have to cycle tree_lock here because reclaim can be still in the
423          * process of removing the last page (in __delete_from_page_cache())
424          * and we must not free mapping under it.
425          */
426         spin_lock_irq(&inode->i_data.tree_lock);
427         BUG_ON(inode->i_data.nrpages);
428         spin_unlock_irq(&inode->i_data.tree_lock);
429         BUG_ON(!list_empty(&inode->i_data.private_list));  <---- HERE

Bug was going down sysfs paths, apparently.
Comment 3 Dave Jones 2012-03-22 13:01:20 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 4 Dave Jones 2012-03-22 13:04:56 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 5 Dave Jones 2012-03-22 13:15:51 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 6 Dave Jones 2012-04-19 12:35:36 EDT
*** Bug 805730 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.