Bug 805730 - [abrt] kernel: kernel BUG at fs/inode.c:429!
[abrt] kernel: kernel BUG at fs/inode.c:429!
Status: CLOSED DUPLICATE of bug 772242
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:9d21192862cb8f4f25d76eecc99...
:
Depends On:
Blocks: kernel_hibernate
  Show dependency treegraph
 
Reported: 2012-03-21 19:05 EDT by Mukund R
Modified: 2012-04-19 12:35 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-19 12:35:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mukund R 2012-03-21 19:05:12 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        BOOT_IMAGE=/vmlinuz-3.2.10-3.fc16.x86_64 root=/dev/mapper/vg_laptop-lv_root ro rd.md=0 rd.dm=0 KEYTABLE=us rd.lvm.lv=vg_laptop/lv_swap quiet SYSFONT=latarcyrheb-sun16 rhgb rd.luks=0 rd.lvm.lv=vg_laptop/lv_root LANG=en_US.UTF-8
kernel:         3.2.10-3.fc16.x86_64
reason:         kernel BUG at fs/inode.c:429!
time:           Wed 21 Mar 2012 07:01:56 PM EDT

backtrace:
:kernel BUG at fs/inode.c:429!
:invalid opcode: 0000 [#1] SMP 
:CPU 0 
:Modules linked in: tcp_lp ppdev parport_pc lp parport fuse ebtable_nat ebtables ipt_MASQUERADE iptable_nat nf_nat xt_CHECKSUM iptable_mangle lockd rfcomm bridge stp llc be2iscsi iscsi_boot_sysfs bnx2i cnic uio cxgb4i cxgb4 cxgb3i libcxgbi cxgb3 mdio ib_iser rdma_cm ib_cm iw_cm ib_sa ib_mad ib_core ib_addr iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi bnep ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack ip6table_filter ip6_tables snd_hda_codec_hdmi snd_hda_codec_realtek joydev arc4 uvcvideo dell_wmi videodev sparse_keymap snd_hda_intel media snd_hda_codec hid_logitech_dj v4l2_compat_ioctl32 btusb bluetooth snd_hwdep snd_seq snd_seq_device dell_laptop dcdbas snd_pcm microcode iwlwifi snd_timer mac80211 snd iTCO_wdt i2c_i801 iTCO_vendor_support soundcore snd_page_alloc cfg80211 rfkill vhost_net macvtap macvlan tun virtio_net kvm_intel kvm uinput sunrpc wmi i915 drm_kms_helper drm i2c_algo_bit i2c_core video [las
:t unloaded: scsi_wait_scan]
:Pid: 1692, comm: python Not tainted 3.2.10-3.fc16.x86_64 #1 Dell Inc.          Dell System XPS L321X/0Y4RM9
:RIP: 0010:[<ffffffff811942cc>]  [<ffffffff811942cc>] end_writeback+0x9c/0xa0
:RSP: 0018:ffff8800d2335e08  EFLAGS: 00010203
:RAX: ffff880115edd580 RBX: ffff880115edd3b0 RCX: dead000000200200
:RDX: 0000000000000001 RSI: ffff880115edd430 RDI: ffff880115edd508
:RBP: ffff8800d2335e18 R08: ffff8800d309c0b0 R09: 0000000000000001
:R10: ffff88010f83ab10 R11: 0000000000000001 R12: ffff880115edd4a8
:R13: ffffffff81616560 R14: ffffffff81616560 R15: ffff880115edd3b0
:FS:  00007f7aa658c700(0000) GS:ffff88011fa00000(0000) knlGS:0000000000000000
:CS:  0010 DS: 0000 ES: 0000 CR0: 000000008005003b
:CR2: 00007f7a9ae98034 CR3: 00000000c7b19000 CR4: 00000000000406f0
:DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
:DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
:Process python (pid: 1692, threadinfo ffff8800d2334000, task ffff8800d46f9730)
:Stack:
: ffff8800d2335e48 ffff880115edd3b0 ffff8800d2335e48 ffffffff81194502
: ffff8801172e1180 ffff880115edd3b0 ffff880115edd430 ffff8801186dcc00
: ffff8800d2335e78 ffffffff81194683 ffff8800d309c000 ffff880115edd3b0
:Call Trace:
: [<ffffffff81194502>] evict+0x122/0x1a0
: [<ffffffff81194683>] iput+0x103/0x200
: [<ffffffff811911d0>] d_kill+0xf0/0x100
: [<ffffffff81191862>] dput+0xe2/0x1b0
: [<ffffffff8117cba6>] fput+0x176/0x220
: [<ffffffff811792e6>] filp_close+0x66/0x90
: [<ffffffff811793a8>] sys_close+0x98/0xf0
: [<ffffffff815ecac2>] system_call_fastpath+0x16/0x1b
:Code: 02 00 00 00 48 c7 c2 90 31 19 81 be 07 00 00 00 e8 3a f2 44 00 48 c7 83 98 00 00 00 60 00 00 00 48 83 c4 08 5b 5d c3 0f 0b 0f 0b <0f> 0b 0f 0b 55 48 89 e5 53 48 83 ec 08 66 66 66 66 90 48 89 fb 
:RIP  [<ffffffff811942cc>] end_writeback+0x9c/0xa0
: RSP <ffff8800d2335e08>

smolt_data:
:
:
:General
:=================================
:UUID: 7d05798c-a2f1-4fd5-bf95-267d6f962bed
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 3392.30
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM) i7-2637M CPU @ 1.70GHz
:CPU Stepping: 7
:CPU Family: 6
:CPU Model Num: 42
:Number of CPUs: 4
:CPU Speed: 1701
:System Memory: 3842
:System Swap: 5951
:Vendor: Dell Inc.
:System: Dell System XPS L321X 
:Form factor: Portable
:Kernel: 3.2.10-3.fc16.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:7245:4136:1326) pci, None, PCI/ISA, QS67 Express Chipset Family LPC Controller
:(32902:278:4136:1326) pci, i915, VIDEO, 2nd Generation Core Processor Family Integrated Graphics Controller
:(32902:7190:4136:1326) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 4
:(32902:7184:4136:1326) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 1
:(32902:7186:4136:1326) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 2
:(32902:7200:4136:1326) pci, snd_hda_intel, MULTIMEDIA, 6 Series/C200 Series Chipset Family High Definition Audio Controller
:(32902:7202:4136:1326) pci, None, SERIAL, 6 Series/C200 Series Chipset Family SMBus Controller
:(7027:4105:4136:1326) pci, xhci_hcd, USB, N/A
:(32902:145:32902:21025) pci, iwlwifi, NETWORK, Centrino Advanced-N 6230 AGN
:(32902:7171:4136:1326) pci, ahci, STORAGE, 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller
:(32902:7213:4136:1326) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2
:(32902:7206:4136:1326) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1
:(32902:260:4136:1326) pci, agpgart-intel, HOST/PCI, 2nd Generation Core Processor Family DRAM Controller
:(32902:7226:4136:1326) pci, None, SIMPLE, 6 Series/C200 Series Chipset Family MEI Controller #1
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_laptop-lv_root / ext4 4096 4096 13081819 9380804 8725444 3276800 2850434 2850434
:/dev/sda1 /boot ext4 1024 1024 508745 433863 408263 128016 127790 127790
:/dev/mapper/vg_laptop-lv_home /home ext4 4096 4096 47691510 46348968 43961410 11943936 11925627 11925627
:
Comment 1 Dave Jones 2012-03-22 10:57:15 EDT
was this after a hibernate ?
Comment 2 Mukund R 2012-03-22 21:06:08 EDT
This was likely after resuming from suspend, but I may be mistaken -- I did resume from hibernate either then, or within about an hour before.
Comment 3 Dave Jones 2012-03-23 10:28:05 EDT
we have a number of open i915/hibernate memory corruption problems. No fix yet.
Comment 4 Josh Boyer 2012-03-28 14:00:22 EDT
[Mass hibernate bug update]

Dave Airlied has found an issue causing some corruption in the i915 fbdev after a resume from hibernate.  I have included his patch in this scratch build:

http://koji.fedoraproject.org/koji/taskinfo?taskID=3940545

This will probably not solve all of the issues being tracked at the moment, but it is worth testing when the build completes.  If this seems to clear up the issues you see with hibernate, please report your results in the bug.
Comment 5 Dave Jones 2012-04-19 12:35:36 EDT

*** This bug has been marked as a duplicate of bug 772242 ***

Note You need to log in before you can comment on or make changes to this bug.