Bug 772336 - [RFE] Ability to specify a different location to store packages/repos
Summary: [RFE] Ability to specify a different location to store packages/repos
Keywords:
Status: CLOSED DUPLICATE of bug 1159270
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Pulp
Version: Unspecified
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
: 1127809 (view as bug list)
Depends On:
Blocks: sat6-pulp-future 1127809
TreeView+ depends on / blocked
 
Reported: 2012-01-06 21:02 UTC by Ashley Penney
Modified: 2019-08-15 03:33 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
: 1127809 (view as bug list)
Environment:
Last Closed: 2015-10-08 13:26:01 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1127809 low CLOSED [RFE] Ability to specify a different location to store packages/repos in Satellite 6 2020-10-14 00:28:05 UTC
Red Hat Knowledge Base (Solution) 1131873 None None None Never

Internal Links: 1127809

Description Ashley Penney 2012-01-06 21:02:48 UTC
Feature request:

As it stands all packages/repos are stored in /var/lib/pulp and I'd like the ability to point these elsewhere (so that my massive packagesets can live on NFS).  Right now I have moved /var/lib/pulp and symlinked it back but I feel this is the wrong approach and it would be better to just define the package storage location.

Comment 1 Kedar Bidarkar 2012-01-27 07:50:04 UTC
I understand that the below 2 bugs are slightly different but think it would be of great help in this context.

https://bugzilla.redhat.com/show_bug.cgi?id=784601(katello)

https://bugzilla.redhat.com/show_bug.cgi?id=784519(rhui)


In short pulp.spec also needs to handle the permissions of the custom/separate disks partitions which stores repos/packages.

Comment 87 Michael Hrivnak 2013-08-22 15:49:37 UTC
For this issue, we recommend mounting dedicated storage either at /var/, /var/lib/, or /var/lib/pulp/. Also note that mongo can quickly use many GB of storage, so consider making plenty of storage available at /var/lib/mongodb/.

Mounting an NFS device within /var/lib/ is quite reasonable. Also consider doing a bind mount, which lets you store the data on any part of your FS hierarchy you like.

/var/lib/ is the appropriate place to store application data. See the Filesystem Hierarchy Standard for details:

http://www.pathname.com/fhs/pub/fhs-2.3.html#PURPOSE31

RHEL uses the FSH as its "authoritative reference": https://access.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Linux/6/html/Storage_Administration_Guide/s1-filesystem-fhs.html

We will certainly consider ways to make it easier for sysadmins to deploy pulp with storage in non-standard locations.

Comment 90 Brian Bouterse 2015-02-19 00:46:56 UTC
Moved to https://pulp.plan.io/issues/162

Comment 91 Brian Bouterse 2015-03-05 22:01:42 UTC
*** Bug 1127809 has been marked as a duplicate of this bug. ***

Comment 92 Brian Bouterse 2015-05-01 15:57:26 UTC
Pulp will ensure that it works with /var/lib/pulp as a symlinked directory and document that this is a supported configuration of Pulp.

Hosting /var/lib/pulp (and other Pulp directories) on NFS is already a tested and supported configuration so that's also an option.

Either way, sat6 should use symlinks or NFS to store content in /var/lib/pulp on another area of the filesystem or other systems. Sat6 will need to configure this at install time. Feel free to needsinfo me with any questions.

Comment 93 pulp-infra@redhat.com 2015-05-01 16:00:47 UTC
The Pulp upstream bug priority is at Normal. Updating the external tracker on this bug.

Comment 94 Bryan Kearney 2015-10-08 13:26:01 UTC

*** This bug has been marked as a duplicate of bug 1159270 ***


Note You need to log in before you can comment on or make changes to this bug.