Bug 772632 - Update of "file" from 5.09 to 5.10 has broken perl dependency generator
Summary: Update of "file" from 5.09 to 5.10 has broken perl dependency generator
Keywords:
Status: CLOSED DUPLICATE of bug 772699
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-01-09 13:33 UTC by Paul Howarth
Modified: 2013-07-02 23:54 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-01-10 08:34:41 UTC
Type: ---


Attachments (Terms of Use)
rpmfcTokens update (710 bytes, patch)
2012-01-09 13:40 UTC, Petr Pisar
no flags Details | Diff

Description Paul Howarth 2012-01-09 13:33:01 UTC
Description of problem:

file version 5.10 has included "magic for /usr/bin/env Perl scripts", which changes the output of "file /path/to/perl/script" from (e.g.) "a /usr/bin/perl -w script, ASCII text executable" to "Perl script, ASCII text executable", which in turn cause rpm not to check it for perl provides/requires.

Changing /usr/lib/rpm/fileattrs/perl.attr from:

%__perl_requires        %{_rpmconfigdir}/perl.req
%__perl_magic           ^.perl .*$
%__perl_flags           exeonly

to:

%__perl_requires        %{_rpmconfigdir}/perl.req
%__perl_magic           ^.*[Pp]erl .*$
%__perl_flags           exeonly

fixes the problem.

More on the problems this is causing can be found at:

http://lists.fedoraproject.org/pipermail/perl-devel/2012-January/044150.html
http://lists.fedoraproject.org/pipermail/devel/2012-January/160958.html

Given that a Rawhide mass rebuild is imminent, this could really do with being fixed urgently.

Comment 1 Petr Pisar 2012-01-09 13:40:10 UTC
Created attachment 551572 [details]
rpmfcTokens update

This patch adds new `Perl script' string to rpmfcTokens array. I'm not sure this is still needed.

Comment 2 Jindrich Novy 2012-01-09 20:02:46 UTC
Fixed in rawhide RPM and rebuilt.

Comment 3 Paul Howarth 2012-01-09 22:07:22 UTC
The patch from Comment #1 on its own does not fix this bug (it does not apply the change mentioned in the original description).

There is a suitable patch attached to Bug #772699, which also addresses a similar issue affecting python code.

Comment 4 Jindrich Novy 2012-01-10 08:34:41 UTC

*** This bug has been marked as a duplicate of bug 772699 ***


Note You need to log in before you can comment on or make changes to this bug.