Bug 772699 - [PATCH] Adapt perl and python fileattrs to changed file 5.10 magics
Summary: [PATCH] Adapt perl and python fileattrs to changed file 5.10 magics
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: rawhide
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
Assignee: Panu Matilainen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 772632 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-01-09 17:23 UTC by Ville Skyttä
Modified: 2012-01-10 10:45 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-01-10 09:01:14 UTC
Type: ---


Attachments (Terms of Use)
Adapt perl and python fileattrs to file 5.10 magics (1.39 KB, patch)
2012-01-09 17:23 UTC, Ville Skyttä
no flags Details | Diff

Description Ville Skyttä 2012-01-09 17:23:59 UTC
Created attachment 551621 [details]
Adapt perl and python fileattrs to file 5.10 magics

file 5.10 has changed magics at least for perl and python scripts, samples:

5.09: a /usr/bin/perl -w script, ASCII text executable, with very long lines
5.10: Perl script, ASCII text executable, with very long lines

5.09: a /usr/bin/python script, ASCII text executable
5.10: Python script, ASCII text executable

The attached patch (against upstream git) adapts fileattrs to these changes.  Marking as high severity because of the ongoing Rawhide mass rebuild; this should get fixed as soon as possible to limit packages being affected.

http://thread.gmane.org/gmane.linux.redhat.fedora.devel/157905

Comment 1 Tomas Mraz 2012-01-10 08:26:57 UTC
This must be added to Rawhide before the mass rebuild starts!

Comment 2 Jindrich Novy 2012-01-10 08:34:41 UTC
*** Bug 772632 has been marked as a duplicate of this bug. ***

Comment 3 Panu Matilainen 2012-01-10 09:01:14 UTC
Thanks Ville. Built into rpm-4.9.1.2-10.fc17 now and also applied upstream.

Comment 4 Petr Pisar 2012-01-10 09:48:45 UTC
I confirm rpm-4.9.1.2-10.fc17 and file-5.10-4.fc17 fixes this bug from point of Perl view by comparing perl.spec binary packages.

Comment 5 Paul Howarth 2012-01-10 10:06:09 UTC
(In reply to comment #4)
> I confirm rpm-4.9.1.2-10.fc17 and file-5.10-4.fc17 fixes this bug from point of
> Perl view by comparing perl.spec binary packages.

Petr, are you planning a bump-and-rebuild of perl in Rawhide now, or should I do one?

Comment 6 Petr Pisar 2012-01-10 10:45:51 UTC
(In reply to comment #5)
> Petr, are you planning a bump-and-rebuild of perl in Rawhide now, or should I
> do one?

I plan to rebuild all affected packages, but currently I'm not able to get exact list of packages as I posted to fedora-devel.

Feel free to rebuild perl now.


Note You need to log in before you can comment on or make changes to this bug.