This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 772640 - New User registration doesn't redirect to the registration page
New User registration doesn't redirect to the registration page
Status: CLOSED DUPLICATE of bug 784873
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.2
Unspecified Unspecified
high Severity high (vote)
: ---
: JON 3.0.1
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On: 772793
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-09 08:51 EST by dsteigne
Modified: 2012-01-30 15:34 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 772793 (view as bug list)
Environment:
Last Closed: 2012-01-30 15:34:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description dsteigne 2012-01-09 08:51:22 EST
Description of problem:
New Users attempting to logon/register on JON 3.0 are redirected to a blank page after authentication.   If they navigate directly to http://server:7080/admin/user/UserAdmin.do?mode=register are able to register and logon.

Version-Release number of selected component (if applicable):
3.0

How reproducible:
Everytime

Steps to Reproduce:
1.Using a clean browser, one that has never logged into the JON server.
2.Navigate to the JON login page and attempt to register as a new user.
3.It will leave a blank white screen with http://server:7180/coregui/ as the url
4.If you navigate directly to the page that it should redirect you to http://server:7080/admin/user/UserAdmin.do?mode=register it will let you complete the registration and login.
  
Actual results:
It will leave a blank white screen with http://server:7180/coregui/ as the url

Expected results:
Should redirect to http://server:7080/admin/user/UserAdmin.do?mode=register to complete the registration and login.

Additional info:
If you are using a browser that previously has logged into JON with an existing user, the new user registration works as it should
Comment 1 Larry O'Leary 2012-01-30 13:48:11 EST
What browser vendor and version was used to reproduce this?
Comment 2 dsteigne 2012-01-30 14:01:29 EST
Reproduced using IE 7 and Firefox 3
Comment 3 Charles Crouch 2012-01-30 15:34:46 EST
Closing this issue as a dupe of 784873. I'll transfer the customer portal issue to the duplicate BZ.
FYI we're aiming to including this in the JON3.0.1 release

*** This bug has been marked as a duplicate of bug 784873 ***

Note You need to log in before you can comment on or make changes to this bug.