Bug 772793 - New User registration doesn't redirect to the registration page
New User registration doesn't redirect to the registration page
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.3
Unspecified Unspecified
high Severity high (vote)
: ---
: ---
Assigned To: Ian Springer
Mike Foley
:
Depends On: jon30-sprint10/rhq43-sprint10
Blocks: 772640 jon310-sprint11/rhq44-sprint11
  Show dependency treegraph
 
Reported: 2012-01-09 19:23 EST by Larry O'Leary
Modified: 2013-08-05 20:42 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 772640
Environment:
Last Closed: 2012-02-07 14:28:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Larry O'Leary 2012-01-09 19:23:30 EST
Description of problem:
New Users attempting to logon/register on JON 3.0 are redirected to a blank page after authentication.   If they navigate directly to http://server:7080/admin/user/UserAdmin.do?mode=register are able to register and logon.

Version-Release number of selected component (if applicable):
3.0

How reproducible:
Everytime

Steps to Reproduce:
1.Using a clean browser, one that has never logged into the JON server.
2.Navigate to the JON login page and attempt to register as a new user.
3.It will leave a blank white screen with http://server:7180/coregui/ as the url
4.If you navigate directly to the page that it should redirect you to http://server:7080/admin/user/UserAdmin.do?mode=register it will let you complete the registration and login.
  
Actual results:
It will leave a blank white screen with http://server:7180/coregui/ as the url

Expected results:
Should redirect to http://server:7080/admin/user/UserAdmin.do?mode=register to complete the registration and login.

Additional info:
If you are using a browser that previously has logged into JON with an existing user, the new user registration works as it should
Comment 1 Ian Springer 2012-01-30 12:59:00 EST
I was not able to reproduce this on HEAD of master using FF9 or FF3.6. QA, would you please see if you can reproduce using JON 3.0? If you succeed, flip it back to ON_DEV, and I'll look into what has changed in master to fix this that was not included in JON 3.0.

Larry, what browser were you using when you saw this?
Comment 2 Larry O'Leary 2012-01-30 14:19:36 EST
IE7, Firefox 3, and Firefox 4.

The important thing is that this must be the first time this browser has been pointed at the server URL. Deleting all browser cookies should also allow you to replicate this.
Comment 3 Ian Springer 2012-01-30 14:31:58 EST
I did Ctrl-Shift-Del in FF and deleted everything - cache, cookies, and everything else, before logging in as my LDAP test user for the first time. And the registration modal window still popped up as it should after I logged in.
Comment 4 Mike Foley 2012-02-01 10:45:09 EST
verified with Google-chrome in icognito mode (first time this browser has been pointed at the URL)
Comment 5 Mike Foley 2012-02-07 14:28:14 EST
changing status of VERIFIED BZs for JON 2.4.2 and JON 3.0 to CLOSED/CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.