Bug 77289 - [PATCH] iso8859-13 support in ttmkfdir
[PATCH] iso8859-13 support in ttmkfdir
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: ttmkfdir (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Yu Shao
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-04 13:06 EST by Nerijus Baliūnas
Modified: 2007-04-18 12:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-19 19:55:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for iso8859-13 support in ttmkfdir (3.34 KB, patch)
2002-11-04 13:09 EST, Nerijus Baliūnas
no flags Details | Diff

  None (edit)
Description Nerijus Baliūnas 2002-11-04 13:06:21 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021018

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
/etc/rc.d/init.d/xfs from XFree86-xfs rpm uses ttmkfdir (from XFree86-font-utils
rpm) to create fonts.scale file in a directory with ttf fonts. Attached is a
patch for ttmkfdir to add support for iso8859-13 encoding and remove fcd8859-15,
which is a pre-standard for iso8859-15 and now removed from XFree86 (see
XFree-fonts/i18n mailing lists). BTW, where ttmkfdir2 is taken from? I created
ttmkfdir2 source by extracting ttmkfdir*patch files from
XFree86-4.2.0-72.src.rpm and patching ttmkfdir2.tar.bz2 with them, a final
result is almost the same as ttmkfdir2.tar.bz2 from
http://people.redhat.com/yshao/. It would be nice if my patch is integrated into
some official ttmkfdir2 distribution. The patch is made using the data from
ftp.unicode.org/Public/MAPPINGS/ISO8859/8859-13.TXT. Please apply, as iso8859-13
support is already added to xtt (XFree86-4.1.0-xtt.patch from XFree86 src rpm).

Regards,
Nerijus


Additional info:
Comment 1 Nerijus Baliūnas 2002-11-04 13:09:40 EST
Created attachment 83531 [details]
patch for iso8859-13 support in ttmkfdir
Comment 2 Mike A. Harris 2002-11-05 09:49:40 EST
ttmkfdir was deprecated, and will be replaced by mkfontscale in the
next release.  There won't be any new releases with a new ttmkfdir so
your feature request is unfortunately a bit late for future Red Hat
Linux releases.  If there were to be a future for ttmkfdir however,
I'd have considered your patch for inclusion.

To answer your other questions..  ttmkfdir2 is a C++ rewrite of the
original ttmkfdir utility that someone did (I don't recall who), and
it has remained in Red Hat Linux for many many releases now.  The
code is ugly, and unmaintained except for some of the fine enhancements
that Yu Shao has made to it over the last few releases to provide
features that we've needed, or clean up bugs and other problems.

mkfontscale, which is also included with RHL 8.0, but just not really
used (it was included for testing) might be more suitable for your needs.
It will be used by default in the next Red Hat Linux release.

mkfontscale is basically a complete rewrite of all of the various random
versions of ttmkfdir floating around, type1-inst and others incorporated
into one unified tool, which will be the default in XFree86 4.3.0.
Comment 3 Nerijus Baliūnas 2003-01-19 16:42:18 EST
In XFree86-xfs-4.2.99.3-20030115.0.i386.rpm from rawhide, ttmkfdir, not
mkfontscale is still used in /etc/rc.d/init.d/xfs. If it will be so in Red Hat
8.1, *please* apply my patch. It will surely not break anything. In fact,
Mandrake patches ttmkfdir (not ttmkfdir2) to add iso8859-13 support for a long time.
Comment 4 Mike A. Harris 2003-01-19 17:16:19 EST
Doh! Sorry..  The decision to kill ttmkfdir has been reverted, however I meant
to dig through bugzilla for ttmkfdir requests and reopen them, but it slipped
my mind.  If you know of any other similar requests that were closed WONTFIX
or similar and think they're relevant, feel free to also reopen them for
consideration.

Reassigning to ttmkfdir component.
Comment 5 Mike A. Harris 2003-01-19 19:49:33 EST
* Sun 12 Jan 2003 Yu Shao <yshao@redhat.com> 3.0.6-1
- added iso8859-13 support from Nerijus Baliunas #77289
- added README


Looks like Yu Shao implemented this already.  Please close as RAWHIDE
once confirmed.
Comment 6 Yu Shao 2003-01-19 19:55:27 EST
Yeah, Mike, I have added the patch. Confirmed.

Note You need to log in before you can comment on or make changes to this bug.