Bug 77300 - Garbled scrollbars in Mozilla with nv driver on nForce
Garbled scrollbars in Mozilla with nv driver on nForce
Status: CLOSED CANTFIX
Product: Red Hat Raw Hide
Classification: Retired
Component: mozilla (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-04 16:48 EST by Mikkel Lauritsen
Modified: 2007-04-18 12:48 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 15:27:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot showing garbled throbber and scrollbar (10.64 KB, image/png)
2002-11-04 16:49 EST, Mikkel Lauritsen
no flags Details
X log file (30.56 KB, text/plain)
2002-11-04 16:50 EST, Mikkel Lauritsen
no flags Details

  None (edit)
Description Mikkel Lauritsen 2002-11-04 16:48:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021029
Phoenix/0.4

Description of problem:
After installing the Rawhide 1101 build of XFree86 the throbber and scrollbars
in Mozilla have become garbled - see the attached screenshot. So far Mozilla is
the only program that I have found to be affected; for example Phoenix has no
problems.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start Mozilla. The throbbers and scrollbars are replaced by what looks like
garbled versions of other bitmaps - the Red Hat Network icon, perhaps?


Additional info:

Athlon XP1800+ on Asus A7N266-VM, Nvidia nForce graphics.
Mozilla 1.1
Comment 1 Mikkel Lauritsen 2002-11-04 16:49:25 EST
Created attachment 83564 [details]
Screenshot showing garbled throbber and scrollbar
Comment 2 Mikkel Lauritsen 2002-11-04 16:50:53 EST
Created attachment 83565 [details]
X log file
Comment 3 Mikkel Lauritsen 2002-11-04 16:51:54 EST
This problem was discovered while investigating bug 75018, BTW.
Comment 4 Mike A. Harris 2002-11-05 05:52:29 EST
That looks like a 2D acceleration bug.  I'll have to report this to
Mark Vojkovich for fixing, but in order to save him some time, I'd like
to do some troubleshooting with you first.

Can you try using:  Option "noaccel" in your XF86Config, restart X and
tell me if the display glitch disappears.

If the problem disappears, remove the noaccel line or comment it out, and
then view the config file manpage (man XF86Config) and near the bottom
you will see various config options listed that start with XaaNoxxxxxx.
Each of these options disables a single 2D acceleration codepath.  I'd
like you to disable one of them at a time, and let me know what option
alone makes the problem go away.  If no single option does it, try using
more than one option and try to narrow it down.

Once you've isolated the options that are required, please attach the
XF86Config that works for you, along with a new X server logfile, and
I can pass this info upstream and it will minimize the amount of
hunting Mark will need to do to attempt a bugfix.  Worst case, it will
allow me to implement a workaround in the driver until it can be fixed
properly.

Thanks.
Comment 5 Mikkel Lauritsen 2002-11-05 17:21:24 EST
Well, I have been poking at things, and I'm getting more and more certain that
it's a bug in Mozilla.

Setting the NoAccel option (which really makes the performance suck, BTW :-)
doesn't make the glitch go away, but upgrading Mozilla to 1.2b makes it disappear.

I'm not much of an X expert, but I've tried installing the CVS build of nv_drv.o
from around october 7 that Mark Vojkovich made, and that doesn't make the
problem disappear either, so something indicates that the problem is caused by
the interaction of Mozilla 1.1 and other parts of X than the driver.

Anyway, I'm currently running Moz 1.2b (with xft by the way, nice work!) on the
021101 build of XFree86, and it's working perfectly.
Comment 6 Mike A. Harris 2002-12-19 06:14:28 EST
Over to the blizmeister
Comment 7 Bill Nottingham 2006-08-07 21:36:37 EDT
'Red Hat Raw Hide' refers to the development tree for Red Hat Linux.
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues were not resolved in a more
timely manner. However, we do want to make sure that important 
don't slip through the cracks. If these issues are still present
in a current release, such as Fedora Core 5, please move these
bugs to that product and version. Note that any remaining Red Hat
Raw Hide bugs will be closed as 'CANTFIX' on September 30, 2006.
Thanks again for your help.
Comment 8 Bill Nottingham 2006-10-18 15:27:07 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.