Bug 75018 - NVidia X server hard crash on nForce
NVidia X server hard crash on nForce
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
8.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-03 15:09 EDT by Mikkel Lauritsen
Modified: 2007-04-18 12:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-07 03:57:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X log file with working driver from current CVS (21.15 KB, patch)
2002-10-07 03:53 EDT, Mikkel Lauritsen
no flags Details | Diff

  None (edit)
Description Mikkel Lauritsen 2002-10-03 15:09:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020827

Description of problem:
When X is started by Anaconda the machine hangs, requiring a hard reset to continue.

Version-Release number of selected component (if applicable):

How reproducible:
Always

Steps to Reproduce:
1. Boot from Psyche CD 1
2. Press return to perform a graphical install

Actual Results:  Video card is detected as GeForce 2 MX.
A couple of seconds later the screen goes black, and the machine hangs completely.

Expected Results:  Working X

Additional info:

Hardware: Asus A7N266VM; the closed-source X driver from NVidia works perfectly
on Redhat 7.3 (as it's being used while writing this bug report :-).

This is the exact same problem as I have previously reported in bug 70022, and
it looks the same as bug 72721 as well.
Comment 1 Mikkel Lauritsen 2002-10-06 16:03:28 EDT
I have tried swapping nv_drv.o for the one available in the official binaries at
xfree86.org, but the behavior is the exact same - a hard lockup. It seems as if
the log files contain no useful information; I guess they get truncated whenever
the machine locks up.
Comment 2 Mikkel Lauritsen 2002-10-07 03:53:18 EDT
Created attachment 79146 [details]
X log file with working driver from current CVS
Comment 3 Mikkel Lauritsen 2002-10-07 03:57:12 EDT
I have tried with a build of nv_drv.o made by Mark Vojkovich from the current
XFree86 CVS and it appears to work perfectly. Of course this doesn't help with the
installer, but hopefully I'm able to get things going in text mode and change the
driver from there.

I have attached a log file made with the working driver.
Comment 4 Mike A. Harris 2002-11-03 05:21:35 EST
I've got XFree86 CVS RPM packages on ftp://people.redhat.com/mharris
which you can test if you like.  Since you've indicated that this is
fixed in CVS, I'm closing the bug report as RAWHIDE, since these CVS
RPM's are going into RAWHIDE this week.
Comment 5 Mikkel Lauritsen 2002-11-03 13:17:54 EST
I can confirm that the CVS build solves the problem - unfortunately introducing
a new bug along the way, but I guess you can't win 'em all :-)

The new bug is that the Mozilla throbber and scrollbars become completely
garbled. Should I report this as a bug on Rawhide, or just wait for a new build?
Comment 6 Mike A. Harris 2002-11-05 05:44:49 EST
Thanks for testing and confirming the problem is fixed in the CVS builds.
I've noticed your new bug report also, and will work with Mark V to try
and find a solution.

Note You need to log in before you can comment on or make changes to this bug.