Bug 773573 - GUI -- keyboard: unexpected behavior of ESC
Summary: GUI -- keyboard: unexpected behavior of ESC
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda
Version: 5.8
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Vratislav Podzimek
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On: 768082
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-01-12 09:57 UTC by Jan Stodola
Modified: 2013-01-08 04:04 UTC (History)
2 users (show)

Fixed In Version: 11.1.2.251-1
Doc Type: Bug Fix
Doc Text:
Cause: The code was checking whether the Cancel button was hit or not (OK, Esc) instead of checking wheter OK button was hit or not. Consequence: Closing dialogs with Esc was handled as if OK was hit, not as if Cancel was hit. Fix: Code now checks whether OK button was hit or not (Esc, Cancel). Result: Closing the dialog with Esc is handled as if the Cancel button was hit.
Clone Of: 768082
Environment:
Last Closed: 2013-01-08 04:04:40 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0038 normal SHIPPED_LIVE anaconda bug fix and enhancement update 2013-01-08 08:38:33 UTC

Comment 1 RHEL Product and Program Management 2012-04-02 08:59:42 UTC
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.

Comment 4 Vratislav Podzimek 2012-06-12 12:22:17 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause:
The code was checking whether the Cancel button was hit or not (OK, Esc) instead of checking wheter OK button was hit or not.

Consequence:
Closing dialogs with Esc was handled as if OK was hit, not as if Cancel was hit.

Fix:
Code now checks whether OK button was hit or not (Esc, Cancel).

Result:
Closing the dialog with Esc is handled as if the Cancel button was hit.

Comment 10 errata-xmlrpc 2013-01-08 04:04:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0038.html


Note You need to log in before you can comment on or make changes to this bug.