Bug 77598 - Installer says cannot allocate memory
Installer says cannot allocate memory
Status: CLOSED DUPLICATE of bug 76123
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-10 03:33 EST by Ryan Djurovich
Modified: 2007-04-18 12:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:50:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ryan Djurovich 2002-11-10 03:33:26 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
Once I have selected all of my preferences for the installation, I press next 
and the screen that displays all of the packages that are being installed 
appears, before it starts installing I get an error titled 'Exception Occured'.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Start annaconda Installer
2.Select Preferences
3.Start Installation
	

Actual Results:  It showed an error message, not allowing me to continue.

Expected Results:  Linux should have started installing.

Additional info:

Traceback (most recent call last):
 File "/usr/lib/anaconda/gui.py", line 786, in handleRenderCallback
  self.currentWindow.renderCallback()
 File "/usr/lib/anaconda/iw/progress_gui.py", line 149, in renderCallback
  self.intf.icw.nextClick ed()
 File "/usr/lib/anaconda/gui.py", line 632, in nextClicked
  self.dispatch.gotoNext()
 File "/usr/lib/anaconda/dispatch.py", line 150, in gotoNext
  self.moveStep()
 File "/usr/lib/anaconda/dispatch.py", line 215, in moveStep
  rc = apply(func, self.bindArgs(args))
 File "/usr/lib/anaconda/packages.py", line 430, in turnOnFilesystems
  partitions.doMetaDeletes(disket)
 File "/usr/lib/anaconda/packages.py", line 1110, in doMetaDeletes
  lvm.vgactivate()
 File "/usr/lib/anaconda/lvm.py", line 54, in vgactivate
  searchPath = 1)
 File "/usr/lib/anaconda/lutil.py", line 66, in execWithRedirect
  childpid = os.fork()
OSError: [Errno 12] Cannot allocate memory
Comment 1 Michael Fulbright 2002-11-11 10:38:34 EST
How much RAM is in your system? The minimum for installation of Red Hat Linux 8
is 64M.
Comment 2 Ryan Djurovich 2002-11-12 00:42:26 EST
I have got 64M, but could it be that the type of RAM is to slow?
Comment 3 case1984 2002-12-28 15:02:38 EST
I'm getting the exact same error message about 90% of the time I try to 
install red hat 8 on my Intel Pentium 200 mmx w/ 2gb HD + 64 mb ram.  The 
other 10% it makes it up to installing the zip library files (about the ninth 
installed file), then fails.
Comment 4 case1984 2002-12-28 22:25:46 EST
I just finished installing Red Hat 8.0!
I couldn't get it to work, but as soon as I allocated 128 mb as a swap 
partition instead of 64 or 65 mb, it worked!
It had failed either right after the installer, or during installation itself 
at least 20 times, but as soon as I switched the swap, it worked the first 
time.  It may not work for you, but it worked for me!
Comment 5 Michael Fulbright 2003-01-02 21:55:48 EST
Did using more swap work for you?
Comment 6 case1984 2003-01-03 03:44:58 EST
Yes, allocating 128mb instead of 64mb to swap worked the first time!  Maybe 
you could change the documentation to suggest 128mb of swap even if the 
computer has 64mb of memory.
case1984@cox.net
Comment 7 Michael Lee Yohe 2003-01-09 09:05:04 EST
This appears to be a duplicate of Bug 76123.  The problem is that there is not
enough memory to process the transactions that are to be executed by the
installer.  Anaconda, in GUI mode, requires at least 64M+ of memory and 128M of
swap.  

You can alternatively attempt to install Red Hat Linux 8.0 in text mode by
specifying "linux text" at the SYSLINUX prompt upon first boot.  Anaconda, in
text mode, is more lenient on memory resources.
Comment 8 Jeremy Katz 2003-02-07 15:47:43 EST

*** This bug has been marked as a duplicate of 76123 ***
Comment 9 Red Hat Bugzilla 2006-02-21 13:50:07 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.