Bug 77697 - gnome-settings-daemon startup error
gnome-settings-daemon startup error
Status: CLOSED DUPLICATE of bug 100562
Product: Red Hat Linux
Classification: Retired
Component: gnome-session (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-12 06:23 EST by Need Real Name
Modified: 2015-01-07 19:01 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:50:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of rpm --root /usr/client/xstation2/ -q -a (9.59 KB, text/plain)
2003-03-06 04:40 EST, erik
no flags Details

  None (edit)
Description Need Real Name 2002-11-12 06:23:13 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
After installing RH 8 on first bootup and all subsequent reboots, the GNOME
login window is replaced with the X window login and the following message is
displayed after login:

"There was an error starting the GNOME Settings Daemon.

Some things, such as themes, sounds, or background settings may not work correctly.

The Settings Daemon restarted too many times.

The last error message was:

Failed to activate 'OAFIID:GNOME_SettingsDaemon

GNOME will still try to restart the Settings Daemon next time you log in."

This prevents various desktop settings and functions from being accessed.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install RH 8 (default settings for GNOME)
2. Boot Machine
3. Log in

Actual Results:  Error message is displayed (see bug description)

Expected Results:  The GNOME Daemon should start without any problem as no
configuration files were changed.

Additional info:
Comment 1 Havoc Pennington 2002-12-13 16:35:44 EST
This only happens to a small number of people. If you have any ideas
how your hardware or configuration may be unique, please advise.
Comment 2 Havoc Pennington 2002-12-13 17:28:57 EST
Niall's machine, received via email:

PC Model: HP Kayak XAs
Processer: PIII 800MhZ
Memory: 512 MB
Disk: SCSI Quantum 8 GB
Video: 64MB ATI Radeon
CD: Generic brand 24x
Comment 3 Havoc Pennington 2003-01-08 00:23:59 EST
Can you try "rpm -Va" and attach the output? (and reopen bug)
Comment 4 erik 2003-03-06 04:40:41 EST
Created attachment 90487 [details]
Output of rpm --root /usr/client/xstation2/ -q -a

Done from NFS server of affected machine
Comment 5 erik 2003-03-06 04:44:03 EST
Happens to me too.

I didn't do a standard install because I couldn't work out how to do that on a
diskless machine (root is NFS - significant?) so perhaps I am missing an RPM (I
didn't use -force to install anything AFAIR). Alternatively perhaps this happens
because I can't shut down normally with an NFS root, so I just pull the plug. 
Since there are no local filesystems this should be OK, but...
Comment 6 erik 2003-03-06 04:45:07 EST
Forgot to mention.  Mine's a VIA C3 Ezra with 800MHz and it was a new RH8.0
installation, not an upgrade.
Comment 7 erik 2003-03-06 13:02:12 EST
Installed control-center, now the error is gone.

A dependency is missing I think
Comment 8 Alexander Larsson 2003-08-27 10:50:17 EDT

*** This bug has been marked as a duplicate of 100562 ***
Comment 9 Red Hat Bugzilla 2006-02-21 13:50:08 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.