Bug 779366 - (SOA-1756) Wise SOAPClient action is unable to invoke oneway methods on the endpoints
Wise SOAPClient action is unable to invoke oneway methods on the endpoints
Status: CLOSED NEXTRELEASE
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: JBossESB (Show other bugs)
5.0.0 ER5
Unspecified Unspecified
urgent Severity urgent
: ---
: 5.0.0 GA,5.0.0 ER8
Assigned To: Kevin Conner
http://jira.jboss.org/jira/browse/SOA...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-22 17:40 EST by Boris Belovic
Modified: 2010-02-10 12:02 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-10 12:02:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
server.log.bz2 (462.82 KB, application/x-bzip2)
2010-02-03 11:35 EST, Boris Belovic
no flags Details
stacktrace.log (4.16 KB, text/plain)
2010-02-06 06:04 EST, Kevin Conner
no flags Details
stacktrace.cp1.log (4.16 KB, text/plain)
2010-02-10 10:06 EST, Kevin Conner
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker JBESB-3083 None Closed Wise SOAPClient action is unable to invoke oneway methods on the endpoints 2012-07-11 10:31:02 EDT
JBoss Issue Tracker SOA-1756 None Closed Wise SOAPClient action is unable to invoke oneway methods on the endpoints 2012-07-11 10:31:02 EDT

  None (edit)
Description Boris Belovic 2009-12-22 17:40:15 EST
Date of First Response: 2010-01-13 05:14:15
project_key: SOA

See linked issue for details.
Comment 1 Boris Belovic 2009-12-22 17:40:35 EST
Link: Added: This issue related JBESB-3083
Comment 2 Tom Fennelly 2010-01-13 05:14:15 EST
A fix for JBESB-3083 has been committed to jbossesb/branches/JBESB_4_7_CP. 
Comment 3 Kevin Conner 2010-01-13 05:19:35 EST
Didn't make ER7
Comment 4 Boris Belovic 2010-02-03 11:26:06 EST
Wise SOAPClient action now invokes Oneway methods correctly, but I am getting *Fatal Error :-1:-1: Premature end of file* after invocation. See console output in this comment, I also attached server.log file. Don't see any relevant exceptions in the log, so I am not sure what exactly is causing this Fatal Error message.

17:15:16,823 INFO  [STDOUT] Message structure: 
17:15:16,823 INFO  [STDOUT] [ message: [ JBOSS_XML ]
header: [ To: JMSEpr [ PortReference < <wsa:Address jms:localhost#queue/wise_oneway_esb/>, <wsa:ReferenceProperties jbossesb:java.naming.factory.initial : org.jnp.interfaces.NamingContextFactory/>, <wsa:ReferenceProperties jbossesb:java.naming.provider.url : localhost/>, <wsa:ReferenceProperties jbossesb:java.naming.factory.url.pkgs : org.jnp.interfaces/>, <wsa:ReferenceProperties jbossesb:destination-type : queue/>, <wsa:ReferenceProperties jbossesb:destination-name : queue/wise_oneway_esb/>, <wsa:ReferenceProperties jbossesb:specification-version : 1.1/>, <wsa:ReferenceProperties jbossesb:connection-factory : ConnectionFactory/>, <wsa:ReferenceProperties jbossesb:persistent : true/>, <wsa:ReferenceProperties jbossesb:acknowledge-mode : AUTO_ACKNOWLEDGE/>, <wsa:ReferenceProperties jbossesb:transacted : false/>, <wsa:ReferenceProperties jbossesb:type : urn:jboss/esb/epr/type/jms/> > ] MessageID: 1e086d11-f5fa-4167-b815-a6badc6a2e64 RelatesTo: jms:correlationID#1e086d11-f5fa-4167-b815-a6badc6a2e64 ]
context: {}
body: [ objects: {request-content=Deferred serialized value: 6e7ce201} ]
fault: [  ]
attachments: [ Named:{}, Unnamed:[] ]
properties: [ {org.jboss.soa.esb.message.transport.type=Deferred serialized value: 5a2384db, org.jboss.soa.esb.message.byte.size=2495, javax.jms.message.redelivered=false, org.jboss.soa.esb.message.source=Deferred serialized value: 51e77418} ] ]
17:15:16,825 INFO  [STDOUT] 
Outbound message:
17:15:16,825 INFO  [STDOUT] <env:Envelope xmlns:env='http://schemas.xmlsoap.org/soap/envelope/'><env:Header></env:Header><env:Body><ns1:sendOneWay xmlns:ns1="http://oneway_wise/helloworld"/></env:Body></env:Envelope>
17:15:16,830 INFO  [STDOUT] @@@@ Hello world from OneWay! @@@@
17:15:16,832 ERROR [STDERR] [Fatal Error] :-1:-1: Premature end of file.
17:15:16,832 INFO  [MessagePayloadProxy] Null data found in message location(s): [org.jboss.soa.esb.message.defaultEntry]
17:15:16,832 INFO  [STDOUT] Message structure: 
17:15:16,832 INFO  [STDOUT] [ message: [ JBOSS_XML ]
header: [ To: JMSEpr [ PortReference < <wsa:Address jms:localhost#queue/wise_oneway_esb/>, <wsa:ReferenceProperties jbossesb:java.naming.factory.initial : org.jnp.interfaces.NamingContextFactory/>, <wsa:ReferenceProperties jbossesb:java.naming.provider.url : localhost/>, <wsa:ReferenceProperties jbossesb:java.naming.factory.url.pkgs : org.jnp.interfaces/>, <wsa:ReferenceProperties jbossesb:destination-type : queue/>, <wsa:ReferenceProperties jbossesb:destination-name : queue/wise_oneway_esb/>, <wsa:ReferenceProperties jbossesb:specification-version : 1.1/>, <wsa:ReferenceProperties jbossesb:connection-factory : ConnectionFactory/>, <wsa:ReferenceProperties jbossesb:persistent : true/>, <wsa:ReferenceProperties jbossesb:acknowledge-mode : AUTO_ACKNOWLEDGE/>, <wsa:ReferenceProperties jbossesb:transacted : false/>, <wsa:ReferenceProperties jbossesb:type : urn:jboss/esb/epr/type/jms/> > ] MessageID: 1e086d11-f5fa-4167-b815-a6badc6a2e64 RelatesTo: jms:correlationID#1e086d11-f5fa-4167-b815-a6badc6a2e64 ]
context: {}
body: [ objects: {response-content={result=null}, request-content={webMethodName=sendOneWay}, response-content-set-stack=java.lang.Exception: setPayload stack trace for 'response-content'.} ]
fault: [  ]
attachments: [ Named:{}, Unnamed:[] ]
properties: [ {org.jboss.soa.esb.message.transport.type=Deferred serialized value: 5a2384db, org.jboss.soa.esb.message.byte.size=2495, jboss.esb:category=MessageCounter,deployment=Wise-One-Way.esb,service-category=WiseWebServices,service-name=OnewayTime=9051292, javax.jms.message.redelivered=false, org.jboss.soa.esb.message.source=Deferred serialized value: 51e77418} ] ]
Comment 5 Boris Belovic 2010-02-03 11:35:26 EST
Attachment: Added: server.log.bz2
Comment 6 Kevin Conner 2010-02-03 11:37:34 EST
Looks like SOAPClient never handled null responses (request/response) so now fails on OneWay.
Comment 7 Boris Belovic 2010-02-04 11:05:18 EST
So what is the resolution for this JIRA? Will there be some additional fixes for SOAPClient?  If yes, this JIRA should be reopen.
Comment 8 Kevin Conner 2010-02-04 11:09:25 EST
I will shortly be creating a new bug to cover this, and will link it here.
Comment 9 Kevin Conner 2010-02-06 06:04:35 EST
The premature end of file originates in the JBossWS codebase, before it gets back to wise.
Comment 10 Kevin Conner 2010-02-06 06:04:35 EST
Attachment: Added: stacktrace.log
Comment 11 Kevin Conner 2010-02-10 10:06:14 EST
Stacktrace from CP1 server
Comment 12 Kevin Conner 2010-02-10 10:06:14 EST
Attachment: Added: stacktrace.cp1.log
Comment 13 Kevin Conner 2010-02-10 10:21:51 EST
Link: Added: This issue related SOA-1945
Comment 14 Boris Belovic 2010-02-10 12:02:53 EST
Verified in CR1. WISE SOAPClient is now able to invoke Oneway methods on WS endpoints. (For premature end of file issue see SOA-1945).

Note You need to log in before you can comment on or make changes to this bug.