Bug 779865 - (SOA-2224) AbstractHttpMethodFactory should extract retry handler parameter in setConfiguration method
AbstractHttpMethodFactory should extract retry handler parameter in setConfig...
Status: CLOSED NEXTRELEASE
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: JBossESB (Show other bugs)
5.0.0 GA
Unspecified Unspecified
high Severity high
: ---
: 5.1.0 GA
Assigned To: Kevin Conner
http://jira.jboss.org/jira/browse/SOA...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-10 12:28 EDT by david.boeren
Modified: 2011-02-10 23:56 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-10 23:56:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SOA-2224 Major Closed AbstractHttpMethodFactory should extract retry handler parameter in setConfiguration method 2013-09-11 05:52:31 EDT

  None (edit)
Description david.boeren 2010-08-10 12:28:14 EDT
Help Desk Ticket Reference: https://access.redhat.com/issue-tracker/?module=issues&action=view&tid=1148953&gid=1354
Workaround Description: There is no known workaround.
project_key: SOA

If you set your config like this:

<action ... class="org.jboss.soa.esb.actions.soap.proxy.SOAPProxy">
    ...
    <property name="http-client-properties">
        <http-client-property name="http.method.retry-handler" value="com.foobar.MyRetryHandler"/>
    </property>

or like this:

<action ... class="org.jboss.soa.esb.actions.soap.proxy.SOAPProxy">
    ...
    <property name="file" value="http-client.properties"/>

http-client.properties:
http.method.retry-handler=com.foobar.MyRetryHandler

, your custom retry handler is not picked up. This is NOT a bug in SOAPProxy.

The bug is in both POSTHttpMethodFactory and GETHttpMethodFactory, where in the setConfiguration(ConfigTree):void method, the http-client-properties that are available in the passed-in ConfigTree are not set into the HttpMethod's HttpMethodParams.

What should happen is that ANY property that starts with "http.method." should be set into the HttpMethodParams.
Comment 1 Kevin Conner 2010-08-10 12:28:47 EDT
Link: Added: This issue depends JBESB-3456
Comment 2 Kevin Conner 2010-08-10 12:29:19 EDT
Link: Added: This issue is related to SOA-2171
Comment 3 Kevin Conner 2010-08-10 12:36:11 EDT
Link: Added: This issue is incorporated by SOA-2210
Comment 4 Kevin Conner 2010-08-11 17:21:04 EDT
It is nor possible to set any property starting with 'http.method.' in HttpMethodParams without writing explicit code to do so.

This task will modify AbstractHttpMethodFactory to correctly extract the parameter and instantiate the handler.
Comment 5 Kevin Conner 2010-08-11 17:21:36 EDT
(not possible)
Comment 6 Kevin Conner 2010-08-12 08:27:37 EDT
The retry handler is configured by specifying the org.jboss.soa.esb.actions.routing.http.routingHandler parameter on the action.  The value of this parameter must be the name of a class which
- implements HttpMethodRetryHandler
- has a public, no-arg constructor
- *may* implement Configurable
Comment 7 Kevin Conner 2010-08-17 09:59:17 EDT
RemoteWsdlLoader is now fixed.
Comment 8 Kevin Conner 2010-08-19 09:49:12 EDT
Reopening to fix SOAPProxy propagation
Comment 9 Kevin Conner 2010-08-19 09:49:41 EDT
Link: Added: This issue depends JBESB-3467
Comment 10 David Le Sage 2011-02-10 23:49:00 EST
Temporarily reopening to update release note info.
Comment 11 David Le Sage 2011-02-10 23:53:20 EST
Release Notes Docs Status: Added: Documented as Resolved Issue
Release Notes Text: Added: https://issues.jboss.org/browse/SOA-2224

If the configuration was set in certain ways, the custom retry handler was not picked up. This was due to a bug in both POSTHttpMethodFactory and GETHttpMethodFactory, whereby the setConfiguration(ConfigTree):void method was not set in the HttpMethod's HttpMethodParams. A task has been added to AbstractHttpMethodFactory to correctly extract the parameter and instantiate the handler. 
Comment 12 David Le Sage 2011-02-10 23:55:48 EST
Release Notes Text: Removed: https://issues.jboss.org/browse/SOA-2224

If the configuration was set in certain ways, the custom retry handler was not picked up. This was due to a bug in both POSTHttpMethodFactory and GETHttpMethodFactory, whereby the setConfiguration(ConfigTree):void method was not set in the HttpMethod's HttpMethodParams. A task has been added to AbstractHttpMethodFactory to correctly extract the parameter and instantiate the handler.  Added: https://issues.jboss.org/browse/SOA-2224

If the configuration was set in certain ways, the custom retry handler was not picked up. This was due to a bug in both POSTHttpMethodFactory and GETHttpMethodFactory, whereby the setConfiguration(ConfigTree):void method was not set in the HttpMethod's HttpMethodParams. A task has been added to AbstractHttpMethodFactory to correctly extract the parameter and instantiate the handler. Note that the retry handler is configured by specifying the org.jboss.soa.esb.actions.routing.http.routingHandler parameter on the action. The value of this parameter must be the name of a class which implements HttpMethodRetryHandler and has a public, no-arg constructor. 
Comment 13 David Le Sage 2011-02-10 23:56:22 EST
Writer: Added: dlesage

Note You need to log in before you can comment on or make changes to this bug.