Bug 80 - CPIO returns 'premature end of file' when extracting (copy in).
CPIO returns 'premature end of file' when extracting (copy in).
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: cpio (Show other bugs)
5.2
All Linux
high Severity high
: ---
: ---
Assigned To: bero
:
: 165 510 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1998-11-15 15:04 EST by gjw
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1998-12-05 20:21:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description gjw 1998-11-15 15:04:04 EST
Trying to install Citrix Winframe Client.
Attempts to 'cpio -icmud < (BIGFILE)'. Errors with
premature end of file. Grabbed cpio-2.4.2-9 src rpm.
Rebuilt, same error. Examine source code. Made cpio manually
with only the sys_errlist patch. the cpio I built manually
then extracted the data from the archive.

I consider this a serious deficency in a necessary
operating system tool.
Comment 1 Bill Nottingham 1998-11-16 08:51:59 EST
*** This bug has been marked as a duplicate of 78 ***
Comment 2 Preston Brown 1998-11-23 07:20:59 EST
*** Bug 165 has been marked as a duplicate of this bug. ***
Comment 3 Preston Brown 1998-11-23 07:22:59 EST
NOT a duplicate of 78, bug still open.
Comment 4 Preston Brown 1998-11-23 07:23:59 EST
*** Bug 165 has been marked as a duplicate of this bug. ***
Comment 5 Jeff Johnson 1998-12-05 20:21:59 EST
This problem is derivative on a fix to a previous problem
reported for Red Hat < 5.2, namely that

	find /any/dir | cpio -oc | cpio -ictv

failed. At the same time that that problem was fixed, the
interpretation of the "-c" flag was made compatible with Solaris
(and presumably all SVR4 systems). The compatibility
was tested by generating cpio archives with the native
cpio on Linux and Solaris and making sure that the cpio
ball could be read on the other system.

However, SVR4 compatibility changed the mapping of -c onto
GNU cpio archive formats. Prior to Red Hat 5.2, "cpio -c" was
equivalent to "cpio -H odc", while in Red Hat 5.2 "cpio -c"
is equivalent to "cpio -H newc".

So, anyone desiring the "old" behavior of cpio should specify
"-H odc" rather than "-c".
Comment 6 Jeff Johnson 1998-12-17 18:06:59 EST
*** Bug 80 has been marked as a duplicate of this bug. ***

Regarding cpio-2.4.2-9.i368.rpm in RedHat 5.2:

Problem noted when installing Citrix client for Linux
(available from www.citrix.com), cpio error when trying to
install.  Downgraded to cpio-2.4.2-6 (shipped with RedHat
5.1 CD), problem disappeared.

Ben Eavey
12/17/1998
beavey@cprma.com

Note You need to log in before you can comment on or make changes to this bug.