Bug 78060 - Installation - Norwegian keyboard is not working.
Installation - Norwegian keyboard is not working.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
: 81052 82093 91801 (view as bug list)
Depends On:
Blocks: 79578
  Show dependency treegraph
 
Reported: 2002-11-18 11:20 EST by Inger Karin Haarbye
Modified: 2007-04-18 12:48 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-30 15:30:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Inger Karin Haarbye 2002-11-18 11:20:57 EST
Description of Problem:
RedHat beta1 - 8.0.90. Graphic installation, norwegian language, norwegian
(latin1) keyboard. 
This gives me the US keyboard on installation. It seems to work after installation. 


Version-Release number of selected component (if applicable):


How Reproducible:
Tried twice. 
Tried both 
norwegian and
norwegian (latin1)


Steps to Reproduce:
1. Norwegian installation
2. no-latin or no keyboard
3. try to write in the dialogs

Actual Results:
US keyboard - as far as I can se.

Expected Results:
Norwegian keyboard

Additional Information:
It seems to work post install.
Comment 1 Jeremy Katz 2002-11-19 14:44:46 EST
Brent -- any ideas here?
Comment 2 Brent Fox 2002-11-19 15:31:50 EST
It uses a Norwegian keymap during the graphical install for me on an 8.0
install, and I don't think anything has changed in that code since then.

haarbye, is this a cdrom based install?
Comment 3 Inger Karin Haarbye 2002-11-19 15:45:10 EST
In 8.0 Norwegian keymap worked for me too (it usually works!), but in 8.0.90 I 
get US keyboard in the dialogs. After installation has finished, norwegian 
keyboard works fine. 
 
And - Yes, it is a cdrom based install.
Comment 4 Brent Fox 2002-11-19 15:55:18 EST
katzj, do you have any cd's of beta1 that we can test?  I don't have any over here.
Comment 5 Brent Fox 2002-11-19 16:31:30 EST
Ok, I've confirmed that the bug occurs in beta1.  I'll have to dig a little
deeper to find out why it's just started happening.
Comment 6 Brent Fox 2002-11-19 16:32:24 EST
However, it does change the keymap to Norwegian on the console, just not in X. 
Hmm....
Comment 7 Brent Fox 2002-11-19 16:50:06 EST
katzj, it looks like the bug is in rhpl somewhere.  In the getNext() function of
keyboard_gui.py, we call kbd.activate.  The activate() function should call
loadkeys (which seems to work) and then fork a call to setxkbmap(this seems to
be failing for some reason).  

The only thing that seems strange to me is that loadkeys is called with an
executils call while setxkbmap is forked and os.execv'd.  Any idea why?

Comment 8 Brent Fox 2002-11-21 16:19:36 EST
Actually, this happens for all keymaps not just Norwegian.  I'm a little
confused because the call to setxkbmap is clearly there, but it looks like it
just isn't being called at all. ?!?
Comment 9 Brent Fox 2002-12-12 15:21:43 EST
The problem still persists in 1212.nightly.  katzj, I really don't have any idea
why this is failing.  Do you?
Comment 10 Jeremy Katz 2002-12-19 11:28:12 EST
I think it might well be fixed in the current tree -- Brent, one of us should
try to remember to try this out today
Comment 11 Brent Fox 2002-12-19 12:17:48 EST
Testing it now...
Comment 12 Brent Fox 2002-12-19 12:29:31 EST
Nope, still broken with re1219.nightly.
Comment 13 Brent Fox 2003-01-03 12:46:03 EST
Looks fixed in re0103.nightly.  Closing as Rawhide.
Comment 14 Inger Karin Haarbye 2003-01-18 17:39:34 EST
It's back again in Beta4 
Comment 15 Brent Fox 2003-01-20 17:38:43 EST
I've verified that this bug has returned.  

Jeremy: any idea what is causing this?  Is it an X problem?  I don't think that
there's any way that this is a redhat-config-keyboard problem.  The keymap is
getting set properly on the console via 'loadkeys', but 'setxkbmap' seems to not
be working.
Comment 16 Brent Fox 2003-01-20 17:38:58 EST
*** Bug 82093 has been marked as a duplicate of this bug. ***
Comment 17 Jeremy Katz 2003-01-20 17:51:20 EST
I don't see how it could be anything other than X assuming setxkbmap gets called
with all of the right arguments.
Comment 18 Brent Fox 2003-01-28 16:01:25 EST
I'm going to transfer this bug to XFree86.  setxkbmap works after reboot, so it
seems like something is wrong with calling setxkbmap only during anaconda. 

redhat-config-keyboard is calling setxkbmap with the exact same arguments during
anaconda as it does after reboot.  The bug is that calling setxkbmap during
anaconda has no effect.

This bug has disappeared and reappeared a few times.  redhat-config-keyboard has
not changed in the way that it calls setxkbmap.
Comment 19 Brent Fox 2003-01-29 11:31:22 EST
Well now with the re0129.nightly tree, setxkbmap is working in the installer. 
Yet I know for a fact that it was not working in yesterday's tree.  

This bug has disappeared and reappeared two or three times now.  What in the
world is going on?
Comment 20 Mike A. Harris 2003-01-30 01:29:08 EST
Changes in -fPIC in X builds?  If not, then it must be some non-X thing.

Either way it looks fixed now, so I'm closing to MODIFIED.  Resolve as
RAWHIDE once satisfied it is fixed.
Comment 21 Mike A. Harris 2003-01-30 01:30:51 EST
*** Bug 81052 has been marked as a duplicate of this bug. ***
Comment 22 Jay Turner 2003-02-06 09:52:22 EST
I'm seeing no problems making use of a German or French keyboard in both TUI and
GUI installations using the re0206.nightly tree.  I've added a GM test case to
cover this, so if it does recur, we'll catch it.
Comment 23 David Balažic 2003-03-27 03:49:46 EST
Jay, you didn't catch it :-(
It is back in RHL9.

Tried Slovenian and German keyboard, none of them works.

(
boot cd1 into GUI install
select Slovenian kbd layout
type something in the disk druid dialog -> it is US layout, not Slovenian
kbd layout on text console VT1-VT6 is correctly Slovenian
)

As I said , this is with Shrike ( Red Hat Linux 9 ).
Comment 24 David Balažic 2003-03-27 05:48:55 EST
It is/was the same with beta5/phoebe3/8.0.94
Comment 25 David Balažic 2003-05-20 13:13:07 EDT
It is back in 9.0.90 ( Cambrigde alpha1 )

Again problem setting Slovene kbd in X during GUI install.
When selected, it is set for the text console , but not in X.

Log on VT3 :

* running ['/usr/X11R6/bin/setxkbmap', '-layout', 'us', '-
model', 'pc105', 'option', '']
* moving (1) to step welcome
* moving (1) to step betanag
* moving (1) to step language
* moving (1) to step keyboard
* running ['/usr/X11R6/bin/setxkbmap', '-layout', 'si', '-model', 'pc105', '-
option', '']

Maybe the empty option parameter is problematic ?
Comment 26 Mike A. Harris 2003-05-21 08:48:31 EDT
Why/how is this an XFree86 bug?
Comment 27 Brent Fox 2003-05-21 12:39:32 EDT
Weird...this seems to work for me in the latest nightly installer.
Comment 28 David Balažic 2003-06-21 06:52:27 EDT
Problem still there in alpha2 ( tried to set slovene keyboard layout )
Comment 29 Mike A. Harris 2003-06-21 17:36:43 EDT
This isn't an XFree86 bug.  Please read the setxkbmap manpage and follow
it to a tee.  If there is a bug in setxkbmap, please provide the exact
commandline which triggers it and step by step instructions on how to
reproduce it in an installed environment, so that it can be investigated.
If there is a bug in setxkbmap, which I definitely can't see from this 
bug report, I need to be able to investigate it on a sane system with
debuggability and I can't do that while anaconda is running during installation.
Comment 30 Mike A. Harris 2003-06-21 17:37:41 EDT
Additionally I note that this "problem" is coming and going randomly as you
describe above, and during all of this time, nothing in XFree86 nor setxkbmap
has changed _at_all_.  Therefore I consider it to be an invocation problem
or some other non-X weirdness.
Comment 31 Bill Nottingham 2003-07-24 01:21:08 EDT
*** Bug 91801 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.