Bug 82093 - Non-US keyboard layouts don't work in GUI install
Summary: Non-US keyboard layouts don't work in GUI install
Status: CLOSED DUPLICATE of bug 78060
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2003-01-17 13:35 UTC by David Balažic
Modified: 2008-01-17 17:49 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2006-02-21 18:51:13 UTC


Attachments (Terms of Use)

Description David Balažic 2003-01-17 13:35:36 UTC
Description of problem:

Non-US keyboard layouts don't work during GUI install.

Version-Release number of selected component (if applicable):

The one from Phoebe CD1 , CD3 contains the following RPM :
anaconda-8.0.92-8.i386.rpm

How reproducible:


Steps to Reproduce:
1. start a GUI install
2. select "Slovenian" keyboard layout
3. proceed until a text box can be used to test the keyboard
    
Actual results:

Keyboard uses US layout, not Slovenian.
( the key between "t" and "u" prints "y" )

Expected results:

Keyboard operates in Slovenian mode.
( the key between "t" and "u" prints "z" )


Additional info:

"z"/"y" is not the only problematic key, all the rest behave like US an not as 
they should.
After the layout is selected, the keyboard on the textual consoles ( VT1, 
VT2 ... ) is set correctly.
Also the keyboard on the installed system is set correctly , both on console 
and X.

I also tested the following layouts :
"German", "Belgian" , "Czechoslovakian"
None of them worked. It also appeared that "Czechoslovakian" did not work on 
VT2 either,
but I don't know the czechoslovakian layout, so I can't be sure.

I also observed the following on VT3: when a new keyboard layout is selected, 
the used command is printed :
setxkbmap -layout <name> -model pc102
All layouts I tried used this cmd line, except US, which used "-model pc105". 
This may be a clue.

Comment 1 Brent Fox 2003-01-20 22:38:55 UTC

*** This bug has been marked as a duplicate of 78060 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:51:13 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.