Bug 782095 - [glusterfs-3.2.6qa1]: if io-cache min-file-size is greater than max-file-size, then glusterd shows the wrong values
[glusterfs-3.2.6qa1]: if io-cache min-file-size is greater than max-file-size...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
pre-release
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Avra Sengupta
:
: GLUSTER-2974 (view as bug list)
Depends On:
Blocks: 849287
  Show dependency treegraph
 
Reported: 2012-01-16 09:00 EST by Raghavendra Bhat
Modified: 2013-07-24 13:20 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 13:20:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Raghavendra Bhat 2012-01-16 09:00:31 EST
Description of problem:
If maximum file size to be cached is lesser than the minimum file size to be cached, then io-cache reconfigure will set both min-file-size and max-file-size to the old value (according to the log message).
[2012-01-16 19:23:30.995499] E [io-cache.c:1673:reconfigure] 0-io-cache: minimum size (23068672) of a file that can be cached is greater than maximum size (23068672). Hence Defaulting to old value

But gluster volume info still shows the wrong input value given by the user only.

gluster volume info

Volume Name: vol
Type: Distribute
Status: Started
Number of Bricks: 1
Transport-type: tcp
Bricks:
Brick1: hyperspace:/mnt/sda7/export4
Options Reconfigured:
performance.cache-max-file-size: 2MB
performance.cache-min-file-size: 22MB
performance.flush-behind: on


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Amar Tumballi 2012-12-20 02:58:00 EST
see if its still valid with master code.
Comment 2 Avra Sengupta 2012-12-20 06:54:11 EST
Checked in master. It is reproducible in master.
Comment 3 Vijay Bellur 2013-02-19 21:58:44 EST
CHANGE: http://review.gluster.org/4541 (glusterd: Added validation function for performance cache max and min size.) merged in master by Anand Avati (avati@redhat.com)
Comment 4 Avra Sengupta 2013-02-21 03:28:46 EST
*** Bug 764706 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.