Bug 764706 - (GLUSTER-2974) volume set for 'cache-min-file-size' succeeds even if 'min-file size' is greater than 'max-file-size'
volume set for 'cache-min-file-size' succeeds even if 'min-file size' is grea...
Status: CLOSED DUPLICATE of bug 782095
Product: GlusterFS
Classification: Community
Component: cli (Show other bugs)
mainline
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Avra Sengupta
: Triaged
Depends On: 764708
Blocks: 849287
  Show dependency treegraph
 
Reported: 2011-06-02 03:29 EDT by M S Vishwanath Bhat
Modified: 2016-05-31 21:55 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 849287 (view as bug list)
Environment:
Last Closed: 2013-02-21 03:28:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Amar Tumballi 2011-06-02 01:18:00 EDT
*** Bug 2976 has been marked as a duplicate of this bug. ***
Comment 1 M S Vishwanath Bhat 2011-06-02 03:29:09 EDT
I did the following operation 

root@tortuga:/tmp# gluster volume set hosdu performance.cache-min-file-size 5MB
Set volume successful
root@tortuga:/tmp# gluster volume set hosdu performance.cache-max-file-size 1MB
Set volume successful

min-file-size for caching exceeds max-file-size for caching. There should be a validation to verify it.

root@tortuga:/tmp# gluster volume info
 
Volume Name: hosdu
Type: Distribute
Status: Started
Number of Bricks: 3
Transport-type: tcp
Bricks:
Brick1: tortuga:/tmp/brick1
Brick2: tortuga:/tmp/brick2
Brick3: tortuga:/tmp/brick3
Options Reconfigured:
performance.cache-max-file-size: 1MB
performance.cache-min-file-size: 5MB
Comment 2 Anand Avati 2011-06-08 09:57:39 EDT
PATCH: http://patches.gluster.com/patch/7362 in master (performance/io-cache: fix the check of min and max file size.)
Comment 3 Anand Avati 2011-06-08 09:58:02 EDT
PATCH: http://patches.gluster.com/patch/7364 in release-3.1 (performance/io-cache: fix the check of min and max file size.)
Comment 4 Anand Avati 2011-06-08 09:58:26 EDT
PATCH: http://patches.gluster.com/patch/7363 in release-3.2 (performance/io-cache: fix the check of min and max file size.)
Comment 5 Amar Tumballi 2011-06-08 10:55:28 EDT
The patches committed fixes the bug 764708. But this bug will remain open.
Comment 6 M S Vishwanath Bhat 2011-06-09 23:54:16 EDT
The issue still persists in 3.2.1qa4... Is this supposed to be fixed in 3.2.1?
Comment 7 Amar Tumballi 2011-06-10 00:15:58 EDT
Bug fix happened is for bug 764708, please verify that.
Comment 8 Amar Tumballi 2012-07-11 01:28:15 EDT
Currently known issue. We don't do the check during the 'volume set' but the check happens when the process is started (volume start/mounting).

I guess, best way to fix it is by fixing bug 762935, so the proper error code can be sent to the user too.


Currently, lets just document this behavior, so that user is aware of such behavior.
Comment 9 Avra Sengupta 2013-02-21 03:28:46 EST
Resolved in http://review.gluster.org/4541.

*** This bug has been marked as a duplicate of bug 782095 ***

Note You need to log in before you can comment on or make changes to this bug.