Bug 78376 - crash when changing the group name of an existing group
Summary: crash when changing the group name of an existing group
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: libuser   
(Show other bugs)
Version: 8.0
Hardware: i386
OS: Linux
high
medium
Target Milestone: ---
Assignee: Miloslav Trmač
QA Contact:
URL:
Whiteboard:
Keywords:
: 121252 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-21 21:22 UTC by Brent Fox
Modified: 2007-03-27 03:58 UTC (History)
0 users

Fixed In Version: 0.51.10-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-02 22:20:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Brent Fox 2002-11-21 21:22:51 UTC
When trying to change the name of an existing group with a little Python script:


#!/usr/bin/python2.2

import libuser

a = libuser.admin()
groupEnt = a.lookupGroupByName('testgroup')
print groupEnt.get(libuser.GROUPNAME)[0]
groupEnt.set(libuser.GROUPNAME, "newname")
print groupEnt.get(libuser.GROUPNAME)[0]
a.modifyGroup(groupEnt)

I get the following error:

[root@bfox tmp]# ./modify.py
newname
testgroup
Traceback (most recent call last):
  File "./modify.py", line 10, in ?
    a.modifyGroup(groupEnt)
RuntimeError: unknown error


I don't think that the error is in the Python script.  Any ideas what's
happening in libuser at this point?  The bug prevents being able to change a
group name with redhat-config-users.  This bug exists as far back as
7.3...perhaps further back but I haven't tested that.

Comment 1 Brent Fox 2003-01-16 21:09:25 UTC
nalin: ping?

Comment 2 Miloslav Trmač 2004-09-01 16:59:31 UTC
*** Bug 121252 has been marked as a duplicate of this bug. ***

Comment 3 Miloslav Trmač 2004-09-02 22:20:08 UTC
Should be fixed in libuser-0.51.10-1, when it hits rawhide.


Note You need to log in before you can comment on or make changes to this bug.