Bug 121252 - traceback when changing a user's username
traceback when changing a user's username
Status: CLOSED DUPLICATE of bug 78376
Product: Fedora
Classification: Fedora
Component: libuser (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Miloslav Trmač
:
: 122090 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-19 15:22 EDT by Brent Fox
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brent Fox 2004-04-19 15:22:38 EDT
I see this problem with system-config-users but I can also reproduce
it manually in the Python interpreter.  In s-c-users, select an
existing user and then click on the "Properties" button in the
toolbar.  Then change the username to something else.  Then hit "OK".
 The following message gets printed out on the command line:

Traceback (most recent call last):
  File "./userProperties.py", line 512, in on_ok_button_clicked
    self.parent.ADMIN.modifyUser(self.userEnt)
RuntimeError: unknown error

If you exit s-c-users, you'll see that libuser actually did make the
correct changes, but the bindings are throwing a traceback for some
reason.
Comment 1 Brent Fox 2004-05-03 10:09:57 EDT
Basically a dupe of bug #78378
Comment 2 Brent Fox 2004-05-03 10:10:50 EDT
*** Bug 122090 has been marked as a duplicate of this bug. ***
Comment 3 Miloslav Trmač 2004-09-01 12:59:19 EDT
Same cause as bug 78376.

*** This bug has been marked as a duplicate of 78376 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:02:40 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.