Bug 784176 - source brick process crashes after starting replace brick operation
source brick process crashes after starting replace brick operation
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
x86_64 Linux
urgent Severity high
: ---
: ---
Assigned To: shylesh
shylesh
:
: 784179 784182 (view as bug list)
Depends On:
Blocks: 817967
  Show dependency treegraph
 
Reported: 2012-01-24 00:52 EST by shylesh
Modified: 2013-07-24 13:47 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 13:47:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions: 3.3.0qa42
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description shylesh 2012-01-24 00:52:59 EST
Description of problem:
By starting a replace-brick operation brick process crashes

Version-Release number of selected component (if applicable):
Mainline

How reproducible:
Always

Steps to Reproduce:
1. created a stripe volume wit h2 bricks
2. started replace brick of b2 with b3

  
Actual results:
b2 process was crashed

Expected results:


Additional info:


(gdb) p *loc
$3 = {path = 0x7f865c0009f0 "/", name = 0x7f865c0009f1 "", inode = 0x7f866c00304c, parent = 0x0,
  gfid = '\000' <repeats 15 times>, pargfid = '\000' <repeats 15 times>}




#0  0x000000390f4a6944 in opendir () from /lib64/libc.so.6
#1  0x00007f866ce42bf8 in posix_opendir (frame=0x7f866f95985c, this=0x1b51850, loc=0x7f866f62c084, fd=0x7f8665e5e04c)
    at posix.c:568
#2  0x00007f866cc2342a in posix_acl_opendir (frame=0x7f866f9597b0, this=0x1b52d80, loc=0x7f866f62c084, fd=0x7f8665e5e04c)
    at posix-acl.c:1067
#3  0x00007f866c9f8a37 in pl_opendir (frame=0x7f866f959704, this=0x1b53f90, loc=0x7f866f62c084, fd=0x7f8665e5e04c)
    at posix.c:388
#4  0x00007f866c7d61aa in iot_opendir_wrapper (frame=0x7f866f9595ac, this=0x1b55130, loc=0x7f866f62c084, fd=0x7f8665e5e04c)
    at io-threads.c:1468
#5  0x00007f8670d8e0d9 in call_resume_wind (stub=0x7f866f62c04c) at call-stub.c:2306
#6  0x00007f8670d98d8e in call_resume (stub=0x7f866f62c04c) at call-stub.c:3853
#7  0x00007f866c7c81cf in iot_worker (data=0x1b66f50) at io-threads.c:138
#8  0x000000390fc077e1 in start_thread () from /lib64/libpthread.so.0
#9  0x000000390f4e577d in clone () from /lib64/libc.so.6


 [2012-01-24 00:38:31.239282] I [pump.c:1598:pump_command_reply] 0-stripe-pump: Command succeeded
[2012-01-24 00:38:31.239944] I [client-handshake.c:1085:select_server_supported_programs] 0-stripe-replace-brick: Using Prog
ram GlusterFS 3git, Num (1298437), Version (310)
[2012-01-24 00:38:31.243564] I [client-handshake.c:917:client_setvolume_cbk] 0-stripe-replace-brick: Connected to 10.1.11.14
0:24011, attached to remote volume '/export/sda/b3'.
[2012-01-24 00:38:31.243594] I [afr-common.c:3473:afr_notify] 0-stripe-pump: subvol 1 came up, start crawl
[2012-01-24 00:38:31.243889] E [posix.c:119:posix_lookup] 0-stripe-posix: null gfid for path /
[2012-01-24 00:38:31.243932] E [posix.c:133:posix_lookup] 0-stripe-posix: lstat on (null) failed: Invalid argument
[2012-01-24 00:38:31.245802] E [posix.c:566:posix_opendir] 0-stripe-posix: null gfid for path /
Comment 1 Anand Avati 2012-01-24 02:25:36 EST
CHANGE: http://review.gluster.com/2681 (cluster/afr: set loc->gfid for building root loc) merged in master by Vijay Bellur (vijay@gluster.com)
Comment 2 krishnan parthasarathi 2012-01-24 04:01:56 EST
*** Bug 784179 has been marked as a duplicate of this bug. ***
Comment 3 Kaushal 2012-03-12 08:32:31 EDT
*** Bug 784182 has been marked as a duplicate of this bug. ***
Comment 4 shylesh 2012-05-23 10:40:15 EDT
Crash does not happens now.

Note You need to log in before you can comment on or make changes to this bug.