This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 784179 - Brick process crashes in replace-brick. (built with lefence)
Brick process crashes in replace-brick. (built with lefence)
Status: CLOSED DUPLICATE of bug 784176
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: krishnan parthasarathi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-24 01:07 EST by Vijaykumar Koppad
Modified: 2015-11-03 18:04 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-24 04:01:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Vijaykumar Koppad 2012-01-24 01:07:12 EST
Description of problem: Whenever you start replace-brick the source brick crashes.

########################
this is the back trace.
########################

#0  0x00007f5804bf4354 in opendir () from /lib/x86_64-linux-gnu/libc.so.6
#1  0x00007f5801633e63 in posix_opendir (frame=0x7f5803c9a824, this=0x7f58023636b8, loc=0x7f580391004c, fd=0x7f57fe4bf014) at posix.c:568
#2  0x00007f580141430d in posix_acl_opendir (frame=0x7f5803c9a778, this=0x7f58023796b8, loc=0x7f580391004c, fd=0x7f57fe4bf014) at posix-acl.c:1067
#3  0x00007f58010e9a43 in pl_opendir (frame=0x7f5803c9a6cc, this=0x7f58013106b8, loc=0x7f580391004c, fd=0x7f57fe4bf014) at posix.c:388
#4  0x00007f5800ec6e97 in iot_opendir_wrapper (frame=0x7f5803c9a574, this=0x7f580132a6b8, loc=0x7f580391004c, fd=0x7f57fe4bf014) at io-threads.c:1468
#5  0x00007f58057b5040 in call_resume_wind (stub=0x7f5803910014) at call-stub.c:2306
#6  0x00007f58057bfb7a in call_resume (stub=0x7f5803910014) at call-stub.c:3853
#7  0x00007f5800eb91b3 in iot_worker (data=0x7f57fff6bee8) at io-threads.c:138
#8  0x00007f5804ee5d8c in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#9  0x00007f5804c3104d in clone () from /lib/x86_64-linux-gnu/libc.so.6
#10 0x0000000000000000 in ?? ()
(gdb) f 0 
#0  0x00007f5804bf4354 in opendir () from /lib/x86_64-linux-gnu/libc.so.6
(gdb) f 1
#1  0x00007f5801633e63 in posix_opendir (frame=0x7f5803c9a824, this=0x7f58023636b8, loc=0x7f580391004c, fd=0x7f57fe4bf014) at posix.c:568
568	        dir = opendir (real_path);
(gdb) f 3 
#3  0x00007f58010e9a43 in pl_opendir (frame=0x7f5803c9a6cc, this=0x7f58013106b8, loc=0x7f580391004c, fd=0x7f57fe4bf014) at posix.c:388
388	        STACK_WIND (frame,
(gdb) f 4 
#4  0x00007f5800ec6e97 in iot_opendir_wrapper (frame=0x7f5803c9a574, this=0x7f580132a6b8, loc=0x7f580391004c, fd=0x7f57fe4bf014) at io-threads.c:1468
1468	        STACK_WIND (frame, iot_opendir_cbk, FIRST_CHILD (this),
(gdb) f 5 
#5  0x00007f58057b5040 in call_resume_wind (stub=0x7f5803910014) at call-stub.c:2306
2306	                stub->args.opendir.fn (stub->frame,
(gdb) f 6 
#6  0x00007f58057bfb7a in call_resume (stub=0x7f5803910014) at call-stub.c:3853
3853	                        call_resume_wind (stub);


#########################################
From the source-brick log file 
########################################


[2012-01-24 11:29:25.068272] W [dict.c:1220:data_to_str] (-->/usr/local/lib/glusterfs/3git/rpc-transport/socket.so(socket_connect+0x42f) [0x7f58025fa116] (-->/usr/local
/lib/glusterfs/3git/rpc-transport/socket.so(socket_client_get_remote_sockaddr+0x28a) [0x7f5802600351] (-->/usr/local/lib/glusterfs/3git/rpc-transport/socket.so(client_f
ill_address_family+0x1ff) [0x7f58025fe9ec]))) 0-dict: data is NULL
[2012-01-24 11:29:25.068666] W [dict.c:1220:data_to_str] (-->/usr/local/lib/glusterfs/3git/rpc-transport/socket.so(socket_connect+0x42f) [0x7f58025fa116] (-->/usr/local
/lib/glusterfs/3git/rpc-transport/socket.so(socket_client_get_remote_sockaddr+0x28a) [0x7f5802600351] (-->/usr/local/lib/glusterfs/3git/rpc-transport/socket.so(client_f
ill_address_family+0x220) [0x7f58025fea0d]))) 0-dict: data is NULL
[2012-01-24 11:29:25.068865] E [name.c:151:client_fill_address_family] 0-doa-replace-brick: transport.address-family not specified and not able to determine the same fr
om other options (remote-host:(null) and transport.unix.connect-path:(null))
[2012-01-24 11:29:26.207661] I [server-handshake.c:540:server_setvolume] 0-doa-server: accepted client from 192.168.1.56:1017 (version: 3git)
[2012-01-24 11:29:26.223655] I [afr-common.c:1839:afr_set_root_inode_on_first_lookup] 0-doa-pump: added root inode
[2012-01-24 11:29:26.230158] E [posix.c:2380:posix_getxattr] 0-doa-posix: null gfid for path /
[2012-01-24 11:29:26.230604] I [client.c:1159:client_setxattr] 0-doa-replace-brick: client rpc init command
[2012-01-24 11:29:26.231263] I [mem-pool.c:573:mem_pool_destroy] 0-doa-replace-brick: size=588 max=0 total=0
[2012-01-24 11:29:26.231542] I [mem-pool.c:573:mem_pool_destroy] 0-doa-replace-brick: size=124 max=0 total=0
[2012-01-24 11:29:26.235015] I [client.c:1937:notify] 0-doa-replace-brick: parent translators are ready, attempting connect on transport
[2012-01-24 11:29:26.236107] I [pump.c:1598:pump_command_reply] 0-doa-pump: Command succeeded
[2012-01-24 11:29:26.237860] I [client-handshake.c:1085:select_server_supported_programs] 0-doa-replace-brick: Using Program GlusterFS 3git, Num (1298437), Version (310
)
[2012-01-24 11:29:26.248610] I [client-handshake.c:917:client_setvolume_cbk] 0-doa-replace-brick: Connected to 192.168.1.56:24011, attached to remote volume '/root/bricks/doa/d5'.
[2012-01-24 11:29:26.248965] I [afr-common.c:3473:afr_notify] 0-doa-pump: subvol 1 came up, start crawl
[2012-01-24 11:29:26.255116] E [posix.c:119:posix_lookup] 0-doa-posix: null gfid for path /
[2012-01-24 11:29:26.255500] E [posix.c:133:posix_lookup] 0-doa-posix: lstat on (null) failed: Invalid argument
[2012-01-24 11:29:26.260853] E [posix.c:566:posix_opendir] 0-doa-posix: null gfid for path /
pending frames:

patchset: git://git.gluster.com/glusterfs.git
signal received: 11
time of crash: 2012-01-24 11:29:26
configuration details:
argp 1
backtrace 1
dlfcn 1
fdatasync 1
libpthread 1
llistxattr 1
setfsid 1
spinlock 1
epoll.h 1
xattr.h 1
st_atim.tv_nsec 1
package-string: glusterfs 3git
/lib/x86_64-linux-gnu/libc.so.6(+0x33d80)[0x7f5804b7ed80]
/lib/x86_64-linux-gnu/libc.so.6(opendir+0x4)[0x7f5804bf4354]
/usr/local/lib/glusterfs/3git/xlator/storage/posix.so(posix_opendir+0x817)[0x7f5801633e63]
/usr/local/lib/glusterfs/3git/xlator/features/access-control.so(posix_acl_opendir+0x330)[0x7f580141430d]


Version-Release number of selected component (if applicable):
glusterfs 3git built on Jan 24 2012 11:12:48
Comment 1 krishnan parthasarathi 2012-01-24 04:01:56 EST

*** This bug has been marked as a duplicate of bug 784176 ***

Note You need to log in before you can comment on or make changes to this bug.