Bug 78438 - Installer crashed [Errno 12]?
Installer crashed [Errno 12]?
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-22 16:22 EST by Charlie Fowler
Modified: 2007-04-18 12:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-24 14:39:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charlie Fowler 2002-11-22 16:22:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; YComp 
5.0.2.4; .NET CLR 1.0.3705)

Description of problem:
Installing 8.0 on an HP e-pc.  No floppy drive.  Has ethernet (rj-45), 
keyboard, mouse, video, sound.  Installing from CD.  Accepted all defaults 
during install up to type.  First time selected Server and changed some of the 
package selections.  Second time selected Workstation and changed some of the 
package selections.  Both times received an "Exception Occurred" error, with 
instructions to post crash dump.  

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Insert Redhat 8.0 CD # 1, and boot.
2. Accept setup defaults up until type selection.  (server, workstation, 
custom etc.)
3. Select any of them, then on the packages screen change some package choices.
4. Setup goes to Installing Packages screen, does not begin to install 
anything, but pops up an "Exception Occured" error message, the contents of 
which I've typed below (since I have no floppy to copy it to, so there may be 
typos... sorry).
	

Actual Results:  Traceback (most recent call last):
File "/usr/lib/anaconda/gui.py", line 786, in handleRenderCallback
 self.currentWindow.renderCallback()
File "/usr/lib/anaconda/iw/progress_gui.py", line 149, in renderCallback
 self.intf.icw.nextClicked()
File"/usr/lib/anaconda/gui.py", line 632, in nextClicked
 self.dispatch.gotoNext()
File "/usr/lib/anaconda/dispatch.py", line 150, in gotoNext
 self.moveStep()
File "/usr/lib/anaconda/packages.py", line 430, in turnOnfilesystems
 partitions.doMetaDeletes(diskset)
File"/usr/lib/anaconda/partitions.py", line 1110, in doMetaDeletes
 lvm.vgactivate()
File "/usr/lib/anaconda/lvm.py", line 54, in vgactivate
 searchPath = 1)
File"/urs/lib/anaconda/iutil.py", line 66, in execWithRedirect
 childpid = os.fork()
OSError: [Errno 12] Cannot allocate memory

Expected Results:  It should have begun to install the packages I had selected.

I cannot install Redhat 8.0 on this machine.

Also tried installing Redhat 7.0 and did NOT experience this problem.

Additional info:

This machine had windows 2000 preinstalled.  I did change the Redhat 
installation partitioning defaults, from use available space to "blow away 
whatever's on here," the first time, the second time, Redhat had already done 
that (the first time) so the default read a bit differently, but still I 
changed it to "blow away whatever's on here."
Comment 1 Michael Lee Yohe 2002-11-22 17:03:26 EST
How much memory is installed on this system?  What does Linux report as it is
booting up? (you can pause the scrolling information by pressing SCROLL LOCK).
Comment 2 Charlie Fowler 2002-11-25 22:18:01 EST
Well, hm.  Thanks to the gentle instruction from Michael@... I don't know if 
this can be classified as a real bug, or a PEBCAK (problem exists between 
keyboard and chair) bug.  Closer inspection on my part reveals Redhat 8.0 
system requirements of 128MB RAM for a graphical installation vs. my target 
machine's 64MB RAM.  It may be a bug since it lets hasty people get pretty far 
down the graphical installation road before quitting, or it may not be a bug 
because hasty people shouldn't be so.  I'm currently more than 65% through a 
what appears to be a successful text based install on the same machine.

thanks (and sorry for taking your time)
abunoah@hotmail.com
Comment 3 Michael Lee Yohe 2003-01-09 09:04:03 EST
This appears to be a duplicate of Bug 76123.  The problem is that there is not
enough memory to process the transactions that are to be executed by the
installer.  Anaconda, in GUI mode, requires at least 64M+ of memory and 128M of
swap.  

You can alternatively attempt to install Red Hat Linux 8.0 in text mode by
specifying "linux text" at the SYSLINUX prompt upon first boot.  Anaconda, in
text mode, is more lenient on memory resources.
Comment 4 Razvan 2005-10-16 08:17:56 EDT
i have an amd athlon 650Mhz, 128MB RAM, 5gb partition on wich to install linux,
g-force 2 mx 200 32mb, samsung 710n monitor  and i tryed to install in graphical
mode and i got the same error. then i tryed to install in text mode and i got
the same error. 
Comment 5 Jeremy Katz 2006-04-24 14:39:02 EDT
Mass-closing lots of old bugs which are in MODIFIED (and thus presumed to be
fixed).  If any of these are still a problem, please reopen or file a new bug
against the release which they're occurring in so they can be properly tracked.

Note You need to log in before you can comment on or make changes to this bug.