Bug 784868 - service bacula-fd does not support chkconfig; cannot be enabled
service bacula-fd does not support chkconfig; cannot be enabled
Status: CLOSED DUPLICATE of bug 784471
Product: Fedora
Classification: Fedora
Component: bacula (Show other bugs)
15
Unspecified Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Simone Caronni
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-26 09:17 EST by John Florian
Modified: 2012-01-26 11:56 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-26 09:25:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Florian 2012-01-26 09:17:50 EST
Description of problem:
Puppet is having a hard time managing the baclua-fd service suddenly after it had been stable for a long time.  It looks like service definition file is written for systemd, yet placed in the traditional SysVinit location:

# systemctl enable bacula-fd.service 
bacula-fd.service is not a native service, redirecting to /sbin/chkconfig.
Executing /sbin/chkconfig bacula-fd on
service bacula-fd does not support chkconfig

# rpm -ql bacula-client  | egrep 'systemd|init'
/etc/rc.d/init.d/bacula-fd

# cat /etc/rc.d/init.d/bacula-fd
[Unit]
Description=Bacula-FileDaemon, a Backup-client
Requires=syslog.target network.target
After=network.target

[Service]
Environment=CONFIG=/etc/bacula/bacula-fd.conf
EnvironmentFile=-/etc/sysconfig/bacula-fd
ExecStartPre=/usr/sbin/bacula-checkconf $CONFIG
ExecStart=/usr/sbin/bacula-fd -f $OPTS -c $CONFIG -u $FD_USER -g $FD_GROUP
IOSchedulingClass=idle
StandardOutput=syslog
Restart=always

[Install]
WantedBy=multi-user.target


Version-Release number of selected component (if applicable):
bacula-5.0.3-19.fc15

How reproducible:
always

Steps to Reproduce:
1. Upgrade to latest version of bacula-client.
2. Attempt to enable service using chkconfig or systemd.
  
Actual results:
Both 'systemctl enable bacula-fd.service' and 'chkconfig bacula-fd enable' fail to enable the service, with each complaining that they don't support it.

Expected results:
One or the other should work.
Comment 1 John Florian 2012-01-26 09:25:14 EST
Please disregard.  I had a problem with the yum meta-data on this machine which prevented the update.  I've since found #784471 which alerted me to the fact that I had an older version in place.  Works now!

*** This bug has been marked as a duplicate of bug 784471 ***
Comment 2 Simone Caronni 2012-01-26 10:03:32 EST
Thanks, yes, is fixed in 5.0.3-22.fc16.

One question, do you had to run ldconfig on applying the update?

Thanks,
--Simone
Comment 3 John Florian 2012-01-26 10:34:25 EST
(In reply to comment #2)
> Thanks, yes, is fixed in 5.0.3-22.fc16.

Yup, I can confirm that.

> One question, do you had to run ldconfig on applying the update?

Nothing of the sort.  You're question had me wondering though since I never bounced the service, it was still/already running.  So just now, I did stop/start the service to verify.  It worked just fine.
Comment 4 Simone Caronni 2012-01-26 10:43:55 EST
Thanks, please see this thread also for additional information in the ongoing issues in the package:

https://bugzilla.redhat.com/show_bug.cgi?id=784587

Regards,
--Simone
Comment 5 John Florian 2012-01-26 11:56:14 EST
Simone,

Thanks for the heads up in that area, although I think I'm pretty safe in that area for now.  Our director installation got upgraded from bacula-2 to bacula-5 by a cohort, to whom I had handed off all backup responsibilities.  He's since left the company, so it's back in my lap now.  I don't recall the exact reasons anymore, but he went with the upstream packages for the director and storage daemons.  So in essence we're not even tracking Fedora's updates on the director.

Still, I appreciate your undertaking of what appears to be a gigantic task and making it "right".  Someday I'm sure I'll be rebuilding that box and it'll be good to get back to tracking Fedora fully there and having this all sorted out.

Now if I only had the time to get my home systems off bacula2!  :-)  Many thanks to whomever made the call to provide the backwards compatibility packages.

Note You need to log in before you can comment on or make changes to this bug.