Bug 785557 - [vdsm][deployUtil] host installation adds interface configured with NM_CONTROLLED="yes" to a bridge which is unsupported.
Summary: [vdsm][deployUtil] host installation adds interface configured with NM_CONTRO...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: vdsm
Version: unspecified
Hardware: x86_64
OS: All
unspecified
high
Target Milestone: ---
: ---
Assignee: Douglas Schilling Landgraf
QA Contact:
URL:
Whiteboard:
: 782102 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-01-29 14:51 UTC by David Naori
Modified: 2012-06-30 18:31 UTC (History)
11 users (show)

Fixed In Version: v4.9.3.3
Doc Type: Bug Fix
Doc Text:
network interface cards that are to be connected to Vdsm network should not be managed by NetworkManager. This particularly relevant to the ovirtmgmt bridge created during installation.
Clone Of:
Environment:
Last Closed: 2012-06-30 18:31:42 UTC
oVirt Team: ---
danken: ovirt_requires_release_note?


Attachments (Terms of Use)

Description David Naori 2012-01-29 14:51:41 UTC
Description of problem:
By default interfaces are configured with NM_CONTROLLED="yes".
host installation flow adds an interface to a bridge and dose not remove the NM_CONTROLLED configuration.

NetworkManager dose not support bridge connections, this way the bridge fails to start after reboot.

Jan 29 18:10:01 pink-vds2 NetworkManager[1606]: NetworkManager[1606]:    ifcfg-rh: parsing /etc/sysconfig/network-scripts/ifcfg-ovirtmgmt ...
Jan 29 18:10:01 pink-vds2 NetworkManager[1606]:    ifcfg-rh:     error: Bridge connections are not yet supported
Jan 29 18:10:01 pink-vds2 NetworkManager[1606]: NetworkManager[1606]:    ifcfg-rh:     error: Bridge connections are not yet supported

Version-Release number of selected component (if applicable):
vdsm-4.9.3.2-0.fc16

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Dan Kenigsberg 2012-01-29 21:10:03 UTC
*** Bug 782102 has been marked as a duplicate of this bug. ***

Comment 2 Dan Kenigsberg 2012-01-30 15:57:34 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
network interface cards that are to be connected to Vdsm network should not be managed by NetworkManager. This particularly relevant to the ovirtmgmt bridge created during installation.

Comment 3 Dan Kenigsberg 2012-02-05 20:34:48 UTC
http://gerrit.ovirt.org/1370
marks all Vdsm-configured devices as non-NM_CONTROLLED, and requires network.service


Note You need to log in before you can comment on or make changes to this bug.