Bug 78619 - deleting a user fails to cleanup leftover files and directories
deleting a user fails to cleanup leftover files and directories
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-users (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-26 11:06 EST by Michael Lee Yohe
Modified: 2007-04-18 12:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-16 16:17:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Lee Yohe 2002-11-26 11:06:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
When you delete a user, the user is effectively deleted (as far as the system is
concerned), but the home directory and mail spool files still remain.

An option should allow the administrator to remove these left over directories
and files should be provided.  This option should be optional so that the
administrator can back these files up - however, on systems where users are
constantly added and deleted, it is important to clean these potentially large
directories and/or files.

Another option to remove any files belonging to said user could be provided to
further clean a system with leftovers.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Delete a user that no longer needs an account using the redhat-config-users
application.	

Actual Results:  User is "deleted" but leftover files remain.

Expected Results:  *see description*

Additional info:

$ rpm -qf `which redhat-config-users`
redhat-config-users-1.1.1-2
Comment 1 Brent Fox 2002-11-26 11:20:22 EST
*** Bug 78620 has been marked as a duplicate of this bug. ***
Comment 2 Michael Lee Yohe 2002-11-26 11:34:17 EST
I filed Bug 78620 (which you marked as a duplicate) - one bug deals with left
over files.  One bug deals with the inability for the application to remove an
entry in the groups file.  Are they necessarily duplicate?
Comment 3 Brent Fox 2002-11-26 12:07:52 EST
Sorry, I read too quickly.  Thanks for the correction.
Comment 4 Brent Fox 2003-01-08 00:46:58 EST
Ok, redhat-config-users-1.1.2-1 now pops up a dialog asking you if you want to
delete the user's home directory.  Thanks for your report.

QA, please verify.
Comment 5 Mike McLean 2003-01-15 21:43:06 EST
* redhat-config-users-1.1.2-2

The dialog is present, but broken.  If you click no, then the dialog exits and
the directory remains, *however* if you click yes, then the dialog remains, and
becomes stuck (so that neither button closes it) and the home directory is not
deleted.

Also, then dialog does not appear at all when the user does not have a private
group.

(You can kill the dialog with the X in on the window dressing, btw)

I propose this feature be merged with the other user delete options.
Please see bug#69712
Comment 6 Brent Fox 2003-01-16 13:08:16 EST
I agree that the delete dialogs should be merged.  However, I'm unable to
reproduce the problem with the program hanging when clicking "No" in the popup
dialogs.  
Comment 7 Brent Fox 2003-01-16 16:17:02 EST
Actually, merging the dialogs was going to look pretty clunky UI wise (it
already was clunky with two separate dialogs anyway.  So I've removed the group
deletion dialog (see bug #78620 for explanation).

Therefore, the dialogs don't need to be merged since the home directory deletion
dialog is the only one shown.  Also, the dialog will not be shown if the user
has no home directory.  Please test with redhat-config-users-1.1.3-3

Note You need to log in before you can comment on or make changes to this bug.