Bug 78638 - Dependencies won't let me install from Develepment tools
Summary: Dependencies won't let me install from Develepment tools
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-packages
Version: 8.0
Hardware: i686
OS: Linux
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Ben Levenson
Depends On:
TreeView+ depends on / blocked
Reported: 2002-11-26 19:52 UTC by Sxren Danielsen
Modified: 2007-04-18 16:48 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2002-11-27 15:50:53 UTC

Attachments (Terms of Use)
screenshot for comment #10 (13.40 KB, image/png)
2003-02-26 15:56 UTC, Michael Schwendt
no flags Details

Description Sxren Danielsen 2002-11-26 19:52:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
When I try and install under Development, development tools (gcc, perl) in
"Kpackage" it says that it needs "krb5-libs" in version 1.2.5-6 but when I
download the version it's asking for and try and install, it says there is a
newer version already installed ?

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Open Kpackage
2.Click on development tools (automake, gcc, perl)
3.Click update (computing package dependecies)

Actual Results:  Can't install the packages I want

Expected Results:  Installation begin, or at least the system installs the
packages needed to continue

Additional info:

Comment 1 Michael Lee Yohe 2002-11-26 20:54:32 UTC
Could you provide the result of "rpm -q krb5-libs" in a console?

Comment 2 Ngo Than 2002-11-26 23:24:25 UTC
we don't support kpackage anymore since 8.0 it's not included, please use
redhat-config-package from 8.0. it's a replacement for kpackage

Comment 3 Sxren Danielsen 2002-11-27 09:15:53 UTC
Reopend the bug because I had made a mistake, when I chose the "component" !
I4m using Danish language on my Red Hat 8.0 installation and thought the 
component was "kpackage", but now I am informed that the package tool in Red 
Hat 8.0 is called "redhat-config-packages" !
Same problem, but now filed under the right place :-)

Comment 4 Mike A. Harris 2002-11-27 13:25:50 UTC
Um..  How exactly is this a "utempter" bug, and why was it
reassigned to me?  I see nothing at all here related to utempter
whatsoever.  Looks like you've filed it under the wrong place.

Reassigning to redhat-config-packages

--- shadow/78638        Wed Nov 27 04:16:00 2002
+++ shadow/78638.tmp.19733      Wed Nov 27 08:19:54 2002
@@ -3,15 +3,16 @@
 Version: 8.0
 Platform: i686
 OS/Version: Linux
 Severity: normal
 Priority: normal
-Component: redhat-config-packages
-AssignedTo: than@redhat.com
+Component: utempter
+AssignedTo: mharris@redhat.com
 ReportedBy: sd@dmclub.dk
 QAContact: benl@redhat.com
+Cc: than@redhat.com
 Summary: Dependencies won't let me install from Develepment tools

Comment 5 Mike A. Harris 2002-11-27 13:28:23 UTC
Now to reassign blame to katzj.  ;o)

Jeremy, what did you do!!  ;o)

Comment 6 Sxren Danielsen 2002-11-27 15:50:47 UTC
For Michael:
The result of "rpm -q krb5-libs"
Is "krb5-libs-1.2.5-7"

That is why I can't believe that it wants an older version, and system can't
install older version ?
Why can't it use the newer version, are packages in Linux not made backward
compatible ?  Or is it a mistake, perhaps mine ?

Comment 7 Jeremy Katz 2002-11-27 16:42:55 UTC
Development libs included krb5-devel which depends on having a specific version
of krb5-libs, not a specific version or newer.

Comment 8 Sxren Danielsen 2002-11-27 20:10:58 UTC
Can't find the package where krb5-devel is hiding, which package do I need to
delete to be able to get rid of it ?

Comment 9 Michael Schwendt 2003-01-29 00:04:12 UTC
Hmm, how was this bug resolved?

It is marked "NOTABUG", but that is hard to believe.

This is a regular problem on mailing-lists and message boards. All of the
following is just IMHO:

Users start with stock krb5-libs package 1.2.5-6 but _without_ packages from the
Development group, that means with krb5-devel _not_ installed. Then they apply
errata updates which pulls in krb5-libs 1.2.5-7. Then they start
redhat-config-packages in order to install Development packages. But
redhat-config-packages fails to solve the dependencies for krb5-devel. Somehow
it relies on the "comps" and "hdlist" files and wants to pull in krb5-libs
1.2.5-6, not knowing that the krb5-devel 1.2.5-7 erratum for the installed
krb5-libs 1.2.5-7 is available at RHN, and complaining that krb5-libs 1.2.5-7 is
too new.

The manual work-around is to install the krb5-devel erratum manually or with
"up2date krb5-devel" prior to running redhat-config-packages.

If I'm far off with this theory, I wonder why this krb5 problem bites many
users? However, if this is exactly what the reporter has experienced, I would
like to learn about what Red Hat has done about this.

Comment 10 Michael Schwendt 2003-02-26 15:55:53 UTC
Reproducable on Phoebe 8.0.94:

After a workstation type of installation I simulated a krb5 errata release. That
means, I took the krb5 source rpm, increased the package release version to 8
and built new packages. I upgraded the installed krb5-libs-1.2.7-7 package to
the newer 1.2.7-8 one as if it were released by Red Hat:

$ rpm -qa 'krb5*'

I then started redhat-config-packages, added "Development" packages and clicked
on "Update". It failed with a critical error for krb5-devel (see attached
screenshot) because (as explained earlier) it doesn't unterstand that the user
has an updated krb5-libs package installed (like those two errata releases for
Psyche) and would need to get a newer and matching krb5-devel from RHN (for
instance). The krb5-devel-1.2.7-7 package on CD would not suffice. 

* depcheck: package krb5-devel needs krb5-libs = 1.2.7-7 (not provided)
('krb5-libs', '1.2.7-7', 8)

Is this specific to "krb5" packages (I doubt that) or is it a fundamental
problem with redhat-config-packages and the comps file? Can installed errata
packages break redhat-config-packages so easily?

Comment 11 Michael Schwendt 2003-02-26 15:56:57 UTC
Created attachment 90379 [details]
screenshot for comment #10

Comment 12 Mark Richardson 2003-03-25 00:53:37 UTC
I recently installed RH 8.0 on a Windows ME system and tried to install VMWare 
when I found this problem.  I need to install "gcc" but can't because of the 
krb5-libs problem.  Being new to Linux I have re-read the above listed comments 
but am still clueless on the solution.  Is it possible to un-install          
krb5-1.2.7-8 and then install -6 via "up2date" or someother means? After 
decades with Windows and all its problems, this "notbug" qualifies as a bug.  I 
hope the Tech Spt folks at RedHat provide a better solution so they don't get 
confused with the folks at RedMond WA

Comment 13 Michael Schwendt 2003-03-25 13:52:00 UTC
I hate duplicate reports. Apparently, bug #83485 is where Jeremy Katz
acknowledged  the problem.

Note You need to log in before you can comment on or make changes to this bug.