Bug 78656 - installer crashes when installing evolution package (says .rpm file cannot be opened)
installer crashes when installing evolution package (says .rpm file cannot be...
Status: CLOSED DUPLICATE of bug 75377
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i586 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-27 00:06 EST by Hari S. Kumar
Modified: 2007-04-18 12:48 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-27 23:14:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Hari S. Kumar 2002-11-27 00:06:02 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
When installing RH8, the installer consistently crashes during installation of 
the evolution package.  As a result, I'm unable to install Red Hat 8 on my 
system - it keeps crashing at the same place in the install process.

This is when it's almost done with installing packages, out of 652 packages 
in "workstation" install mode, it had successfully installed 596.

The error dialog that comes up says that it could not open:

/mnt/sysimage/var/tmp/evolution-1.0.8-10.i386.rpm

When I hit <return> after reading the error message, I get a stack trace and an 
unhandled exception message asking me to report the stack trace to bugzilla.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install RH8 in "workstation" mode.
2. Choose pretty much all the default options, no customization.
3.
	

Actual Results:  The install process goes fine until the package installation 
phase.  Out of 652 total packages, it installs the first 596 just fine 
(transitioning to CD #2 through the process).  When it gets to evolution-1.0.8-
10 it reports an error and then crashes.

Expected Results:  Should have either installed evolution successfully, or 
skipped on and installed the next package.  I am currently unable to install 
Red Hat at all on my system - every time I try it keeps crashing at the same 
place in the install process.

Additional info:

Here're my detailed observations when I took notes the second time this 
happened.  These notes include the stack trace from anaconda:

during installation of Red Hat 8.0, in "workstation" mode:
while beginning to install package:
evolution-1.0.8-10
26,412 KBytes

install status was:
total packages: 652 (1888M)
completed: 596 (1428M)
remaining: 56 (460M)

got the following error message:

The file /mnt/sysimage/var/tmp/evolution-1.0.8-10.i386.rpm cannot be opened.
This is due to a missing file, a bad package, or bad media.
Press <return> to try again.

After pressing return, got the following error:

An unhandled exception has occurred.  This is most likely a bug.
Please copy the full text of this exception or save the crash dump to a floppy
then file a detailed bug report against anaconda at
http://bugzilla.redhat.com/bugzilla

The following text was in a text box in the error message:

Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 786, in handleRenderCallback
    self.currentWindow.renderCallback()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 149, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 632, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 150, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 215, in moveStep
    rc = apply(func,self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 719, in doInstall
    problems = ts.run(0, ~rpm.RPMPROB_FILTER_DISKSPACE,cb.cb,0)
  File "/usr/lib/anaconda/packages.py", line 283, in cb
    fn = self.method.getFilename(h,self.pkgTimer)
  File "/usr/lib/anaconda/image.py", line 119, in getFilename
    f = open("/mnt/source/.discinfo")
IOError: [Errno 2] No such file or directory: '/mnt/source/.discinfo'

Clicked on "save to floppy" and got the attached dump file.
Comment 1 Michael Lee Yohe 2002-11-27 00:54:05 EST
This appears to be a duplicate of Bug 75377.  Please refer to the instructions
in that bug report to see if the updated image provided will correct your problem.
Comment 2 Hari S. Kumar 2002-11-27 09:57:49 EST
Hi,

I looked at the bug you pointed me at (75377) and I'm not sure it addresses the 
problem I have.

Also, I am very much a newbie to Linux.  I don't know exactly how to go about 
implementing the various solutions described by the bug report above.  I have 
two computers at home: one is the system I'm trying to install Linux on, the 
other is a Win2K system.  Apart from that I do not have other Linux resources, 
and I'm not sure what it means to use the floppy instead of the provided CDs 
etc.  Could you please help me by providing more details or steps?

Thank you,
Hari :-)
Comment 3 Michael Lee Yohe 2002-11-27 23:14:47 EST
From Bug 75377 - "If you hit a case where a package can't be read and you get
prompted to try again, you can end up in a case where the CD isn't mounted, so
trying to read the .discinfo file fails."

I have not experienced the problem that seems to occur regular enough that
people are having difficulties installing Red Hat Linux 8.0.  So, I'll try to
summarize the solution that's included in the aforementioned bug:

The boot portion of the Red Hat Linux 8.0 installation disc and Anaconda, the
Red Hat Linux installer, were designed with the philosophy that even the "gold"
edition could have bugs that hinder Red Hat Linux being installed on certain
systems.  The .discinfo problem seems to be sort of a timing issue -
specifically related to certain CD-ROM drives (I might be over-simplifying the
problem).  Nonetheless, people filed the bug in Bugzilla - the Red Hat engineers
went to work to create an update image.

When you first put in the Red Hat Linux 8.0 disc 1, it shows you a text screen
showing some options.  Typing "linux updates" at the prompt let's the
installation know that you have a disk that contains some patches or workarounds
to get rid of a problem.  You will then be asked to provide the disk that you
wrote the image on.

See the following steps:

1. Since you have a Windows machine - you should first obtain the rawwritewin
application.  You can find the rawwritewin application at the following address:
ftp://mirror.hiwaay.net/redhat/redhat/linux/8.0/en/os/i386/dosutils/rawritewin/

Download all the files in the directory to your local computer.  "rawwritewin"
will take an image (like the image file mentioned in the bug report) and
byte-for-byte write it to your floppy disk.

2. You should then download the actual image to be written to the floppy disk.
http://people.redhat.com/~katzj/8.0-cdread.img - place the 8.0-cdread.img file
in a convenient location.

3. Put a 1.44M floppy disk in your drive - make sure you don't mind losing
everything on the disk!

4. Double-click "rawwritewin.exe" (where ever you put the file) - it will pop-up
a dialog box that says "Write", "Read", etc. in the tabs.  The Floppy Drive
selection box should already be set to your default A: drive.  Click the "..."
button to the right of the Image file: text box.  Now, find the image that you
downloaded - Click OK.  Now click the "Write" button in the lower right of your
tab area.  This will byte-for-byte write the update disk to your floppy.

5. Now you are ready to install Red Hat Linux 8.0 again!

6. Boot off disc 1.

7. Text will appear (the SYSLINUX menu) - at the prompt type: linux updates

8. Follow the instructions and you should be good-to-go.

I hope this helps you out.
Comment 4 Michael Fulbright 2002-12-02 11:06:47 EST

*** This bug has been marked as a duplicate of 75377 ***

Note You need to log in before you can comment on or make changes to this bug.