Bug 78721 - cups 1.1.15 can't handle printing landscape mode (e.g. via a2ps)
Summary: cups 1.1.15 can't handle printing landscape mode (e.g. via a2ps)
Keywords:
Status: CLOSED DUPLICATE of bug 68914
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: cups
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-28 10:49 UTC by Andreas Donath
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2002-11-28 10:49:45 UTC


Attachments (Terms of Use)

Description Andreas Donath 2002-11-28 10:49:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020826

Description of problem:
When I want to print ascii text in landscape mode, piped through a2ps 
printouts are always coming out in portrait mode, getting the rest cut off.
 What I want is:
+==========================+
" +---------+ +----------+ "
" |         | |          | "
" |         | |          | "
" |   1     | |   2      | "
" |         | |          | "
" |         | |          | "
" |         | |          | "
" +---------+ +----------+ "
+==========================+
 What I get is:
+===============+
"               "
"               "
" +-------+ +---"
" |       | |   "
" | 1     | | 2 "
" |       | |   "
" |       | |   "
" +-------+ +---"
"               "
"               "
+===============+
(thanks to Jeroen Dijkmans for the sketch)

This is really a hassle because lots of my customers are
used to print like that and I cannot upgrade the server
without having that "feature" switched off.  



Version-Release number of selected component (if applicable):
cups 1.1.15

How reproducible:
Always

Steps to Reproduce:
1.a2ps -r foo.txt 
2.
3.
	

Actual Results:  see "Description"

Expected Results:  getting 2 pages printed on 1 in landscape mode
see "Description"

Additional info:

This bug seems to be known by the cups developers and
was fixed in version 1.1.16 when I get the www.cups.org changelog right.
vups Version 1.1.14 in RH 7.3 does not seem to have that problem...

Comment 1 Tim Waugh 2002-11-28 11:07:43 UTC
Already noted in bug #68914.

*** This bug has been marked as a duplicate of 68914 ***


Note You need to log in before you can comment on or make changes to this bug.