Bug 787467 - Virt is very slow after suspend / resume
Virt is very slow after suspend / resume
Status: CLOSED DUPLICATE of bug 714271
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Justin M. Forbes
Fedora Extras Quality Assurance
:
: 806533 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-05 05:29 EST by drago01
Modified: 2012-06-05 11:11 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-05 11:11:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description drago01 2012-02-05 05:29:34 EST
Description of problem:
After suspending and resuming the host virtualization using kvm is very slow (feels like qemu is emulating everything without any hardware support and has constant 94-100% cpu load) reloading the kvm_intel and kvm modules does not help.

After a reboot everything is back to normal.

Version-Release number of selected component (if applicable):
3.2.2-1.fc16.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Start kvm guest
2. Notice that it is fast (no noticeable slowdown)
3. Shut down guest
4. Suspend host
5. Resume host
6. Boot guest
7. Notice that it takes forever to boot while cpu load being high and the performance of the guest is crap (useless).
  
Actual results:
Slow guest after suspend

Expected results:
Guest performance should not be slower just because the host had a suspend / resume cycle (even when the guest was not even booted before the suspend).

Additional info:
This is on an Intel(R) Core(TM) i7 CPU         920  @ 2.67GHz 
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm sse4_1 sse4_2 popcnt lahf_lm ida dts tpr_shadow vnmi flexpriority ept vpid
Comment 1 Dave Jones 2012-03-22 12:48:18 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 2 Dave Jones 2012-03-22 12:52:48 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 3 Dave Jones 2012-03-22 13:03:16 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 4 drago01 2012-03-22 13:05:02 EDT
(In reply to comment #3)
> [mass update]
> kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
> Please retest with this update.

Unfortunately it is still broken i.e no change.
Comment 5 Julian Sikorski 2012-03-27 15:10:32 EDT
*** Bug 806533 has been marked as a duplicate of this bug. ***
Comment 6 Julian Sikorski 2012-03-27 15:13:24 EDT
My configuration:
model name	: Intel(R) Core(TM) i7-2720QM CPU @ 2.20GHz
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx lahf_lm ida arat epb xsaveopt pln pts dts tpr_shadow vnmi flexpriority ept vpid
Comment 7 Julian Sikorski 2012-03-27 15:54:45 EDT
This is the smolt profile of my machine used as a host:
http://www.smolts.org/client/show/pub_1eec606f-137a-46a1-922f-98f40180efa6
The qemu command line from /var/log/libvirt/qemu/beefy_miracle.log:

LC_ALL=C PATH=/sbin:/usr/sbin:/bin:/usr/bin QEMU_AUDIO_DRV=spice /usr/bin/qemu-kvm -S -M pc-0.14 -enable-kvm -m 2048 -smp 4,sockets=4,cores=1,threads=1 -name beefy_miracle -uuid e9ad7942-a182-77ed-7752-216337e3b401 -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/beefy_miracle.monitor,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=utc -device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x7 -drive file=/var/lib/libvirt/images/beefy_miracle.img,if=none,id=drive-virtio-disk0,format=raw -device virtio-blk-pci,bus=pci.0,addr=0x5,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=1 -netdev tap,fd=24,id=hostnet0,vhost=on,vhostfd=25 -device virtio-net-pci,netdev=hostnet0,id=net0,mac=52:54:00:a8:27:8b,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=serial0 -chardev spicevmc,id=charchannel0,name=vdagent -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=com.redhat.spice.0 -usb -device usb-tablet,id=input0 -spice port=5900,addr=127.0.0.1,disable-ticketing -vga qxl -global qxl-vga.vram_size=67108864 -device intel-hda,id=sound0,bus=pci.0,addr=0x4 -device hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x6
Comment 8 Cole Robinson 2012-06-05 11:11:17 EDT

*** This bug has been marked as a duplicate of bug 714271 ***

Note You need to log in before you can comment on or make changes to this bug.