This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 806533 - llvmpipe inside VM is ridiculously slow
llvmpipe inside VM is ridiculously slow
Status: CLOSED DUPLICATE of bug 787467
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-24 08:13 EDT by Julian Sikorski
Modified: 2012-03-27 15:10 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-27 15:10:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.log (96.27 KB, text/x-log)
2012-03-24 08:13 EDT, Julian Sikorski
no flags Details

  None (edit)
Description Julian Sikorski 2012-03-24 08:13:40 EDT
Created attachment 572434 [details]
Xorg.log

Description of problem:
Since the latest xorg-x11-drv-qxl update the gnome-shell crashes are gone, but the llvmpipe performance is still unusably slow. Opening any new window requires a dozen seconds wait, and gdb initialisation is almost just as slow.
My machine has i7-2720M cpu and 4 GB of RAM, and I have assigned 4 virtual cores and 2 GB to the guest.
Whenever the wait happens, I can see 100% usage of 1 core on the host's gnome-system-monitor.
/var/log/Xorg.0.log on the guest contains some suspicious messages, so I'm attaching it too.

Version-Release number of selected component (if applicable):
xorg-x11-drv-qxl-0.0.22-0.fc17.x86_64
gnome-shell-3.3.92-1.fc17.x86_64

How reproducible:
always

Steps to Reproduce:
1. Install F-17 x86_64 guest on a F-16 x86_64 host
2. Boot it
3. Change it to use spice
  
Actual results:
Guest is slooooooow

Expected results:
Guest is snappy and quick

Additional info:
Feel free to reassign if gnome-shell is not the right component.
Comment 1 Adam Jackson 2012-03-27 13:08:34 EDT
If you ssh into the guest, where is the CPU time being spent?

What version of mesa are you using in the guest?  Can you try this one and see
if it's any better?  (It can't possibly be worse)

https://admin.fedoraproject.org/updates/mesa-8.0.1-7.fc17

Does dmesg on the host report any problem with kvm?
Comment 2 Julian Sikorski 2012-03-27 15:10:32 EDT
Summing up the IRC session:
The new mesa did not help.
"top" has shown that time is being spent in gnome-shell process.
It eventually turned out that this bug might be a duplicate of bug 787467.

*** This bug has been marked as a duplicate of bug 787467 ***

Note You need to log in before you can comment on or make changes to this bug.