Bug 78756 - Installation Exception Occured while Installing Packages on Redhat 8.0 gui
Installation Exception Occured while Installing Packages on Redhat 8.0 gui
Status: CLOSED DUPLICATE of bug 76123
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2002-11-29 00:00 EST by Need Real Name
Modified: 2007-04-18 12:48 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 13:50:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-11-29 00:00:01 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows 98; DigExt)

Description of problem:
Installing on a Toshiba Satellite Pro 425CDS.  Tried twice with GUI install 
tool.  Exception occurs when Installing Packages page is submitted.  

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.  Tried RedHat installation 2x.  Blows up same on submition of Installing 
Packages page.

Actual Results:  Traceback( most recent call last):
File "/usr/lib/anaconda/gui.py", line 786, in handleRenderCallback
File "/usr/lib/anaconda/gui.py", line 149, in renderCallback
File "/usr/lib/anaconda/gui.py", linae 632, in nextClicked
File "/usr/lib/anaconda/dispatch.py", line 150, in gotoNext
File "/usr/lib/anaconda/dispatch.py", line 215, in moveStep
 rc = apply(func, self,bindArgs(args))
File "/usr/lib/anaconda/packages.py", line 430, in turnOnFilesystems
File "/usr/lib/anaconda/partitions.py", line 1110, in doMetaDeletes
File "/usr/lib/anaconda/lvm.py", line 54, in vgactivate
 searchPath = 1)
File "/usr/lib/anaconda/iutil.py", line 66, in execWithRedirect
 childpid = os.fork()
OSError: [Errno 12] Cannot allocate memory

Expected Results:  Should build.

Additional info:
Comment 1 Need Real Name 2002-12-02 10:03:57 EST
This same exception also occurse on this system from the 'linux text' 
installation during the same spot.  The system displayed the depencency widget, 
the formatting file system widget before the error message was productd.
Comment 2 Michael Fulbright 2002-12-02 11:04:04 EST
How much RAM is in your system?
Comment 3 Need Real Name 2002-12-02 14:08:05 EST
Currently there is 40M of ram and kernel 2.4.7-10 is running a modified server 
version with Redhat7.2 package versions of all software.
Comment 4 Michael Lee Yohe 2003-01-09 09:01:11 EST
This appears to be a duplicate of Bug 76123.  The problem is that there is not
enough memory to process the transactions that are to be executed by the
installer.  Anaconda, in GUI mode, requires at least 64M of memory.

You can alternatively attempt to install Red Hat Linux 8.0 in text mode by
specifying "linux text" at the SYSLINUX prompt upon first boot.
Comment 5 Jeremy Katz 2003-01-10 01:55:25 EST

*** This bug has been marked as a duplicate of 76123 ***
Comment 6 Greg Hinds 2003-01-29 23:26:17 EST
What is the resolution?
Comment 7 Red Hat Bugzilla 2006-02-21 13:50:14 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.